4. GeoShop Administrator Tools

4.1. Einleitung

Die GeoShop Administrator Tools bestehen aus folgenden Dienstprogrammen:

GeoShop Administrator

Verwaltung von Benutzer und Zugriffsrechten, allgemeine Server Konfiguration und Überwachung.

GeoShop Ordermanager

Verwaltung von Bestellungen.

GeoShop Publisher

Publizieren von Daten im Internet. Der GeoShop Publisher besteht aus den Dienstprogrammen geoedit.exe und den Konfigurationseditoren der INTERLIS Tools. Diese Dienstprogramme sind in den separaten Dokumentationen [4] und [9] beschrieben.

Die Administrator Tools kommunizieren über Internet oder Intranet mit dem GeoShop Server. D.h. über die Administrator Tools kann der GeoShop Server vollständig fernverwaltet werden.

4.2. GeoShop Administrator

4.2.1. Aufruf

Aufruf über GeoShop Java Runtime Environment

Der GeoShop Administrator wird wie folgt aufgerufen.

GEOSHOP_DIR\jre\bin\java.exe -jar GEOSHOP_DIR\system\bin\admin.jar

Aufruf über Doppelclicken

Falls die Java Runtime Umgebung auf dem System installiert ist, kann der GeoShop Administrator durch Doppelclicken folgender Datei aufgerufen werden.

GEOSHOP_DIR\system\bin\admin.jar

Aufruf über Batch-Datei

Erstellen Sie ein Batch-File

GEOSHOP_DIR\user\bin\admin.bat

Fügen Sie folgenden Inhalt ein.

@echo off
title GeoShop Administrator
..\..\jre\bin\java -jar ..\..\system\bin\admin.jar -server localhost:3501 -user Administrator -password infogrips

Mit den Argumenten -server, -user und -password können Sie bereits die Anmeldeinformationen mitgeben, die Sie dann in der Maske der Anmeldung nicht immer einzugeben brauchen.

Auf dem Desktop können Sie einen Link auf das Batch-File erstellen.

4.2.2. Anmeldung

Melden Sie sich unter einem Benutzer mit admin Privileg an. Dazu gehen Sie wie folgt vor:

  1. Füllen Sie die Felder Server, User und Password aus.

  2. Klicken sie auf den Login Knopf.

Sobald Sie mit dem Server verbunden sind, wird im Statusbalken eine entsprechende Meldung ausgeben. Über das Menü File>Logout können Sie sich wieder abmelden.

4.2.3. Menü Users

Mit dem Menü Users können neue Benutzer im System eingerichtet bzw. bestehende verändert oder gelöscht werden. Das Menü besteht aus zwei Teilen. Auf der linken Seite werden die bestehenden Benutzer als Liste angezeigt. Auf der rechten Seite werden detailierte Angaben zu dem aktuell ausgewählten Benutzer angezeigt. So zeigen Sie einen bestimmten Benutzer an:

  1. Laden Sie mit Refresh die Liste der im System definierten Benutzer.

  2. Klicken Sie in der Liste auf einen Benutzer. Der Benutzer wird zum aktuellen Benutzer. Die Daten des aktuellen Benutzers werden im rechten Teil des Menüs angezeigt.

So ändern Sie die Eigenschaften des aktuellen Benutzers:

  1. Verändern Sie die Daten im rechten Teil des Menüs. Unter Other Properties können Sie alle Eigenschaften eines Benutzers festlegen (z.B. Privilegien oder Defaultwerte).

  2. Klicken Sie auf Save.

So erzeugen Sie einen neuen Benutzer:

  1. Klicken Sie auf Refresh. Der rechte Teil des Menüs wird dadurch initialisiert.

  2. Geben Sie einen Benutzernamen im Feld Name und das Passwort in den Feldern Password und Confirm Password ein.

  3. Klicken Sie auf Create.

So löschen Sie einen bestehenden Benutzer:

  1. Wählen Sie den gewünschten Benutzer in der Benutzerliste aus.

  2. Klicken Sie auf Delete.

4.2.4. Menü Server>Processes

Mit dem Menü Server>Processes können die aktuell im System angemeldeten Benutzer und die Jobs in der Jobqueue angezeigt werden. So zeigen Sie die im System angemeldeten Benutzer an:

  1. Laden Sie mit Refresh (oben rechts) die Liste der im System angemeldeten Benutzer. Mit Kill können Sie den selektierten Benutzerprozess abbrechen.

So zeigen Sie die aktuell in der Jobqueue enthaltenen Jobs an:

  1. Laden Sie mit Refresh (mitte rechts) die Liste der aktuell in der Jobqueue enthaltenen Jobs. Im Status Feld wird der aktuelle Bearbeitungszustand jedes Jobs angezeigt.

So verändern Sie den Status eines Jobs:

  1. Klicken Sie auf den Job den Sie verändern wollen.

  2. Mit Start kann der Job gestartet werden (Voraussetzung: der Job war vorher im Zustand STOPPED).

  3. Mit Stop kann ein Job gestopped werden.

  4. Mit Delete kann ein Job gelöscht werden (Voraussetzung: der Job war vorher im Zustand WAITING oder STOPPED). Achtung: Falls Sie Bestellungsjobs löschen, werden die Kunden davon nicht automatisch benachrichtigt.

[Anmerkung]

Doppelklick auf einen Job öffnet die aktuelle .log Datei des Jobs.

4.2.5. Menü Server>Servers

Mit dem Menü Server>Servers können die aktuell im System registierten Server (ICS Server, Geomapserver, Hauptserver) angezeigt werden. Mehr als ein Server wird nur bei aktivierter Skalierungsoption angezeigt. So zeigen Sie die im System registrierten Server an:

  1. Laden Sie mit Refresh (oben rechts) die Liste der im System angemeldeten Server. Unter State wird angegeben ob ein Server im Moment am Arbeiten ist (idle bzw. working).

  2. Sobald Sie auf einen Server klicken, werden die dem Server zugewiesenen Dienste (Services) angezeigt. Durch Klicken auf den Service können Sie die dem Server die verfügbaren Dienste zuordnen oder auch wieder entziehen. Änderungen müssen Sie mit Save speichern. Nach Änderungen unter Services empfiehlt sich normalerweise ein Restart des betroffenen Server.

    [Anmerkung]

    Der Dienst geoshop (GeoShop Hauptprozess) darf nur einem Server zugeordnet werden.

Mit Restart können Sie einen Server frisch starten. Mit Restart All werden alle Server neu gestartet.

[Anmerkung]

Sie können einen Server sogar dann starten, wenn aktuell ein oder mehrere Jobs ausführt werden. Die Jobs werden nach dem Restart automatisch fortgesetzt.

4.2.6. Menü Server>GeoShop

Mit dem Menü Server>GeoShop können die wichtigsten Dienste des GeoShop Servers aktivert bzw. deaktiviert werden. So schalten Sie einen Dienst ein oder aus:

  1. Der User Login kann durch die Selektionsbox User Login aktiviert werden. Falls der User Login deaktiviert wird, können sich nur noch Benutzer mit admin Privileg im System anmelden. Achtung: Alle bereits im System angemeldeten Benutzer werden beim deaktiviern des User Login nicht automatisch ausgelogged.

  2. Die Jobqueue kann durch die Selektionsbox Job Queue aktiviert werden. Falls die Joqqueue deaktiviert wird, werden keine weiteren Jobs im System ausgeführt. Ein allfällig bereits gestarteter Job wird zu Ende geführt.

  3. Der Loader kann über die Loader Selektionsbox ein- bzw. ausgeschaltet werden.

4.2.7. Menü Server>Data

Mit dem Menü Server>Data können Sie mit dem Loader geladene INTERLIS Dateien verfügbar machen (Mount), temporär deaktivieren (Dismount) oder permanent löschen (Delete).

So machen Sie eine INTERLIS Datei verfügbar:

  1. Klicken Sie auf Refresh unter Models um die Liste der aktuell verfügbaren INTERLIS Datenmodelle anzuzeigen und selektieren Sie das gewünschte Datenmodell.

  2. Klicken Sie auf Refresh unter Files um alle Dateien eines Modells anzuzeigen. Danach klicken Sie auf die gewünschte Datei.

  3. Klicken Sie auf Mount. Auf die INTERLIS Datei kann nun über den GeoShop Client zugegriffen werden (graphische Darstellung und Bestellung).

So deaktivieren Sie eine INTERLIS Datei temporär:

  1. Selektieren Sie die gewünschte Datei.

  2. Klicken Sie auf Dismount. Auf die INTERLIS Datei kann nun über den GeoShop Client nicht mehr zugegriffen werden bis die Datei Mount wieder verfügbar gemacht wird. Achtung: Beim Serverstart werden alle Dateien automatisch wieder gemounted.

So löschen Sie eine INTERLIS Datei permanent:

  1. Selektieren Sie die gewünschte Datei.

  2. Klicken Sie auf Delete. Die Datei und alle davon abhängigen Dateien ( Indexdateien, Layers, Datenbankeinträge, post_upload etc.) werden permanent aus dem System entfernt.

4.2.8. Menü Server>Log

Mit dem Menü Server>Log kann die Logdatei DATA_DIR\logs\serverlogs\appserver.log angezeigt werden. So können Sie die Logdatei anzeigen:

  1. Wählen Sie unter Filter die Meldungen aus an denen Sie interessiert sind.

  2. Klicken Sie auf Refresh.

Bedeutung der einzelnen Meldungskategorien:

debug

Debugmeldung. Diese Meldungen sind nur für Entwickler von Bedeutung. Debugmeldungen werden nur ausgegeben, wenn im Menü Options die entsprechende Option aktiviert wird.

message

Normale Meldung. Z.B. es wurde ein Job gestartet.

warning

Es wurde etwas entdeckt, dass später zu einem Fehler führen kann. Z.B. es wurde noch kein Abbildungsskript für ein Datenmodell installiert.

error

Es ist ein Fehler aufgetreten, der Fehler führte jedoch nicht zu schwerwiegenden Systemstörungen.

syserror

Schwerwiegender Systemfehler. Syserror's werden per E-Mail an den Systemverantwortlichen gemeldet.

security

Es wurde versucht unter einem ungültigen Benutzer/Passwort auf den GeoShop Server zuzugreifen.

[Anmerkung]

Mit tail werden nur die letzten 100 Zeilen von appserver.log angezeigt, sonst die ganze .log Datei.

4.2.9. Menü Config>Options

Mit dem Menü Config>Options können Sie alle Optionen des GeoShop Servers setzen. Die Optionen werden auf dem Server in der Datei USER_DIR\options\appserver.opt gespeichert. So verändern Sie Optionen:

  1. Laden Sie mit Refresh die Liste der verfügbaren GeoShop Module.

  2. Wählen Sie unter Modules den Modul aus für den Sie eine eine Option verändern wollen.

  3. Klicken Sie auf die Option und geben Sie den neuen Wert in Value ein.

  4. Klicken Sie auf Save.

4.3. GeoShop Ordermanager

4.3.1. Aufruf

Aufruf über GeoShop Java Runtime Environment

Der GeoShop Ordermanager wird wie folgt aufgerufen.

GEOSHOP_DIR\jre\bin\java.exe -jar GEOSHOP_DIR\system\bin\order.jar

Aufruf über Doppelclicken

Falls die Java Runtime Umgebung auf dem System installiert ist, kann der GeoShop Ordermanager durch Doppelclicken folgender Datei aufgerufen werden.

GEOSHOP_DIR\system\bin\admin.jar

Aufruf über Batch-Datei

Erstellen Sie ein Batch-File

GEOSHOP_DIR\user\bin\order.bat

Fügen Sie folgenden Inhalt ein.

@echo off
title GeoShop Ordermanager
..\..\jre\bin\java -jar ..\..\system\bin\order.jar -server localhost:3501 -user Order -password infogrips

Mit den Argumenten -server, -user und -password können Sie bereits die Anmeldeinformationen mitgeben, die Sie dann in der Maske der Anmeldung nicht immer einzugeben brauchen.

Auf dem Desktop können Sie einen Link auf das Batch-File erstellen.

4.3.2. Anmeldung

Melden Sie sich unter einem Benutzer mit order Privileg an. Dazu gehen Sie wie folgt vor Dazu gehen Sie wie folgt vor:

  1. Füllen Sie die Felder Server, User und Password aus.

  2. Klicken sie auf den Login Knopf.

Sobald Sie mit dem Server verbunden sind, wird im Statusbalken eine entsprechende Meldung ausgeben. Über das Menü File>Logout können Sie sich wieder abmelden.

4.3.3. Menü Order

Mit dem Menü Order können Sie die aktuell auf dem Server gespeicherten Bestellungen anzeigen bzw. löschen.

So zeigen Sie eine Bestellungen an:

  1. Klicken Sie auf Refresh.

  2. Klicken Sie auf die gewünschte Bestellung. Auf der rechten Seite des Menüs werden dann weitere Angaben zur Bestellung angezeigt.

So löschen Sie eine Bestellung:

  1. Wählen Sie eine Bestellung aus der Liste aus.

  2. Klicken Sie auf Remove. Die Bestellung und alle dazugehörigen Daten wird auf dem Server gelöscht.

4.3.4. Menü Download

Mit dem Menü Download können Sie alle auf dem Server gespeicherten Bestellungen in einer Textdatei abspeichern. Die Textdatei wird so formatiert, dass Sie als Datenquelle für einen Word Serienbrief benutzt werden kann.

So speichern Sie die Bestellung in einer Textdatei:

  1. Geben Sie den vollständigen Namen (d.h. inkl. Laufwerksbuchstaben) der Textdatei im Feld to Textfile ein.

  2. Klicken Sie auf Download. Alle Bestellung werden in der lokalen Textdatei gespeichert.