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1. Einleitung
Das IL2SHP Benutzerhandbuch beschreibt den infoGrips INTERLIS => SHP Translator
(kurz IL2SHP). Mit IL2SHP können beliebige INTERLIS 1 Transferdateien in SHP-
Dateien (= Format von ESRI ArcView) umgewandelt werden. IL2SHP kann sehr flexibel
auf die Bedürfnisse des Benutzers konfiguriert werden. IL2SHP verfügt dazu über
folgende Eigenschaften:

• Einen eingebauten INTERLIS-Compiler.

• Automatische Topologieberechnung für AREA- und SURFACE-Typen.

• Volle Programmierbarkteit mit der Skriptsprache iG/Script.

Trotz der Flexibilität bleibt die Konfigurierung von IL2SHP einfach und kann auch von
gelegentlichen Benutzern durchgeführt werden. Dies wird vor allem durch den IL2SHP-
Konfigurationseditor ermöglicht, mit dem IL2SHP-Konfigurationen über eine
Windowsoberfläche editiert werden können. Im Lieferumfang von IL2SHP ist ausserdem
eine Konfiguration für das INTERLIS-Datenmodell AV93 enthalten, so dass der
Benutzer IL2SHP auch ohne eigenen Konfigurationsaufwand direkt einsetzen kann.

IL2SHP ist ein Bestandteil des Produktes INTERLIS Tools, kann aber auch einzeln
lizenziert werden.

1.1 Allgemeines zu IL2SHP
Die Software IL2SHP besteht aus folgenden Teilen:

1. Der ICS-Runtimeumgebung. Mit der Runtimeumgebung können die mit dem
Konfigurationseditor erstellten Konfigurationen mit dem infoGrips Conversion Sy-
stem (ICS) ausgeführt werden. Die Bedienung der ICS-Runtimeumgebung ist in
Kapitel 3 beschrieben.

2. Dem IL2SHP-Konfigurationseditor. Mit dem Konfigurationseditor können neue
Konfigurationen generiert oder bestehende Konfigurationen angepasst werden.
Der Konfigurationseditor ist in Kapitel 4 beschrieben.

In der  folgenden Graphik ist der allgemeine Aufbau der Software dargestellt:
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1.2 Aufbau des Handbuchs
Das Benutzerhandbuch ist wie folgt aufgebaut:

• In Kapitel 2 wird die Installation von IL2SHP beschrieben.

• In Kapitel 3 wird die Bedienung der ICS-Runtimeumgebung beschrieben.

• In den Kapiteln 4 ist der IL2SHP-Konfigurationseditor beschrieben.

• In Kaptiel 5 wird auf die fortgeschrittenen Konfigurationsmöglichkeiten mit
iG/Script eingegangen.

• Im Anhang ist das Literaturverzeichnis enthalten.

Konventionen:

fett Definitionen, Funktions- und Produktnamen, Menüeinträge.
courier Eingaben im Betriebssystem oder Dateien.
kursiv Dateinamen.
[1] Verweis auf das Literaturverzeichnis im Anhang.

1.3 Ergänzende Dokumentationen
Das Benutzerhandbuch wird durch folgende Dokumentationen ergänzt:

• INTERLIS Tools Benutzerhandbuch zur Installation und Bedienung der
INTERLIS Tools.

• iG/Script Benutzer- und Referenzhandbuch. Im iG/Script Benutzer und Refe-
renzhandbuch ist die Skriptsprache iG/Script im Detail beschrieben.

• ICS Konfigurationshandbuch. In diesem Handbuch sind alle in einer IL2DXF
Konfiguration zur Verfügung stehenden Prozeduren und Methoden beschrieben.

• INTERLIS ein Daten-Austausch-Mechanismus für Landinformationssysteme.
Beschreibt die Datenmodellierungssprache INTERLIS.

• ESRI Shapefile Technical Description. Beschreibt das SHP-Format.
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2. Installation
Der IL2SHP Konfigurationseditor ist ein Bestandteil der INTERLIS Tools und wird mit
den INTERLIS Tools installiert und lizenziert.
Beachten Sie daher die Installationsanleitung im INTERLIS Tools Benutzerhandbuch
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3. Bedienung

3.1 Bedienung mit ICS for Windows
Nachfolgend ist die Bedienung der ICS-Runtimeumgebung mit der Oberfläche ICS for
Windows beschrieben:

1. Aktivieren Sie das Programm über den Windows Start-Knopf mit:

Start > Programme > infoGrips INTERLIS Tools > ICS for Windows

2. Wählen Sie mit System Script ... die Konfiguration Grunddatensatz.cfg
(oder die von Ihnen gewünschte Konfiguration) im Unterverzeichnis il2shp aus.

3. Starten Sie die Konfiguration Grunddatensatz.cfg mit Run.

4. ICS for Windows fragt die INTERLIS-Inputdatei und das Output-Directory für die
Shapefiles ab. Bemerkung: Falls Sie die Eingabe mit Abbrechen abschliessen,
wird auch der Skript abgebrochen. Weiter mit Schritt 2, 3 oder Cancel.

5. ICS for Windows übersetzt nun die Inputdatei . Die Outputdateien werden im
Output-Directory erzeugt. Fehlermeldungen werden in die Logdatei
ILTOOLS_DIR\data\temp\ics.log geschrieben.

6. Sie können die Logdatei nach Beendigung des Skripts mit Show Log anzeigen.

Während der Übersetzung wird die Anzahl INTERLIS-Inputobjekte und die Anzahl er-
zeuger SHP-Objekte angezeigt. Die Anzahl der Input- und Outputobjekte ist normaler-
weise nicht identisch. Die Anzahl hängt von der gewählten Konfiguration und der Struk-
tur des INTERLIS- bzw. SHP-Datenmodells ab.
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3.2 Bedienung über ein DOS-Fenster
In einem DOS-Fenster kann IL2SHP wie folgt aufgerufen werden:

IL2SHP <Konfigurationsdatei> <Transferdatei> <Verzeichnis>

Für <Konfigurationsdatei> geben Sie die IL2SHP-Konfiguration an die Sie
benutzen wollen (z.B. Grunddatensatz.cfg). Für <Transferdatei> geben Sie die zu
übersetzende INTERLIS-Transferdatei und für <Verzeichnis> das Outputverzeichnis
an. IL2SHP übersetzt darauf die Inputdatei und gibt Meldungen und Fehler auf den
Bildschirm bzw. in die Logdatei ics.log aus. Sie können die Logdatei mit jedem Texteditor
anzeigen oder ausdrucken.

Damit Sie IL2SHP von der DOS Kommandozeile aus in einem beliebigen Verzeichnis
starten können, müssen Sie die PATH-Variable um das bin-Verzeichnis von
ICS for Windows erweitern. Die Variable können Sie wie folgt
definieren:

• Öffnen Sie in der Windows-Systemsteuerung:

System>Erweitert>Umgebungsvariablen

• Definieren oder erweitern Sie die Variable PATH als Systemvariable oder
Benutzervariable um den Anteil

c:\iltools15\system\bin

 (Annahme: die INTERLIS Tools  wurde unter c:\iltools15 installiert).

• Melden Sie sich in Ihrem System ab und wieder an, oder starten Sie den PC neu.
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4. IL2SHP-Konfigurationseditor
Mit IL2SHP wird die Basiskonfiguration Grunddatensatz.cfg mitgeliefert. Die
Konfiguration Grunddatensatz.cfg ist für das Datenmodell AV93 (offizielles Datenmodell
der V+D) [2] vorkonfiguriert. Mit dem Konfigurationseditor kann der Benutzer die
mitgelieferte Konfiguration anpassen oder neue Konfigurationen erstellen. Bemerkung:
IL2SHP-Konfigurationen sollten nur mit dem Konfigurationseditor und nie von Hand
editiert werden.

4.1 Starten des Konfigurationseditors
Aktivieren Sie das Programm über den Windows Start-Knopf. Falls der
Konfigurationseditor korrekt installiert wurde, erscheint das Hauptmenü des
Konfigurationseditors auf dem Bildschirm:

Der Konfigurationseditor ist nun für das Bearbeiten von Konfigurationen bereit. Der
Konfigurationseditor kann mit File>Exit wieder verlassen werden. Bemerkung: Der
Konfigurationseditor registiert die wichtigsten Benutzeraktionen in der Logdatei
ILTOOLS_DIR\temp\shpedit.log. Die Logdatei kann mit File>Show Log ...
angezeigt werden.

4.2 Laden und Anzeigen von Konfigurationen
Wählen Sie mit File>Open User ... oder File>Open System ... die
Konfiguration aus die Sie anzeigen wollen. Im View INTERLIS Objects werden alle
verfügbaren INTERLIS-Topics der aktuellen Konfiguration angezeigt. Falls Sie auf das +
Zeichen neben einem Topic klicken, werden alle Tabellen des Topics unterhalb des Topics
dargestellt. Sie können nun auf eine Tabelle klicken. Die Attribute der Tabelle werden im
View Attributes of <Table> dargestellt:
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Im View Attributes of <Table> werden neben den Attributnamen auch die Typen
der Attribute dargestellt (z.B. Atttribut Nummer, Typ TEXT). Die Typenbezeichungen
entsprechen den INTERLIS-Bezeichnungen bis auf folgenden Ausnahmen:

TID: Transferidentifikation (nur für Attribut OBJID möglich).
IRANGE: Wertebereich von ganzen Zahlen (z.B. [0 .. 10]).
RRANGE: Wertebereich von reellen Zahlen (z.B. [0.0 .. 1.0]).
ENUM: Aufzählungstyp.

Ausserdem werden folgende spezielle Attribute dargestellt:

OBJID: Dieses Attribut enthält die Transferidentifikation.
GEOM: Linienattribut aus AREA- oder SURFACE-Tabellen.

Z.B. BoFlaeche_Geometrie oder LFPNachführung_Perimeter.
GEOM wird auch für mit dem Topologiemodul berechnete Flächen
angezeigt.

REFID: Beziehungsattribut aus SURFACE-Tabellen.
Attr_TXT: Textdarstellung eines Aufzählungsattributs Attr.

Falls zu der INTERLIS-Tabelle SHP-Objekte konfiguriert wurden, werden diese im View
SHP Objects dargestellt:

Die Felder der SHP-Objekte sind in die Gruppen Parameters und Attributes unter-
teilt. Die Gruppe Parameters enthält Felder die die geometrische Lage des Objekts
beinflussen (z.B. Geom = Position). Die Gruppe Attributes enthält die SHP-
Objektattribute (z.B. File). Bei mehreren SHP-Objekten pro Tabelle, wird nur ein SHP-
Objekt auf einmal angezeigt. Sie können die anderen SHP-Objekte anzeigen, in dem Sie
auf den Reiter des gewünschten Objekts klicken. Bemerkung: Falls zu einer INTERLIS-
Tabelle SHP-Objekte konfiguriert wurden, dann erscheint neben der INTERLIS-Tabelle
ein blaues Kreuz im View INTERLIS Objects.

Spezielle Darstellungen
Falls auf der linken Seite einer Tabelle ein + Zeichen zu sehen ist, sind zu dieser Tabelle
Zusatzkriterien definiert worden. Sie können die Zusatzkriterien anzeigen, indem Sie auf
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das + Zeichen klicken. Es ist möglich, dass in einem Zusatzkriterium weitere Zusatzkri-
terien definiert wurden (in diesem Fall steht links des Zusatzkriteriums ein + Zeichen).

Falls neben einem Attribut im Attributview ein + Zeichen steht, handelt es sich bei dem
Attribut um ein Beziehungsattribut. Falls Sie auf das + Zeichen klicken, werden die
Attribute der referenzierten Tabelle angezeigt (hier: Beziehungsattribut Entstehung
mit Attributen aus der referenzierten Tabelle LFPNachführung).

4.3 Erzeugen von neuen Konfigurationen
So erstellen Sie eine neue Konfiguration:

1. Wählen Sie File>New

2. Im Untermenü wählen Sie das INTERLIS-Modell aus (.ili). Das Modell kann
entweder aus ILTOOLS_DIR\user\models (User ...) oder
ILTOOLS_DIR\system\models (System ...) ausgewählt werden.

3. Mit OK wird die neue Konfiguration für Sie erstellt (noname.cfg). Die Konfigura-
tion kann nun wie unter 4.4 beschrieben, editiert werden.

4.4 Ändern einer Konfiguration

Definieren von Zusatzkriterien
Falls Sie Objekte aus der gleichen INTERLIS-Tabelle in SHP unterschiedlich abbilden
möchten, müssen Sie Zusatzkriterien für die Tabelle definieren. So definieren Sie
Zusatzkriterien:

1. Wählen Sie die Tabelle aus.

2. Wählen Sie aus ein Attribut vom Typ ENUM aus.

3. Klicken Sie auf INTERLIS>New Condition.

4. Der Konfigurationseditor fügt darauf alle möglichen Werte des Aufzählungsattri-
buts als neue Zusatzkriterien ein.
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Bemerkungen:
• Zusatzkriterien könnnen mit INTERLIS>Delete Condition gelöscht werden.

• Es ist möglich innerhalb eines Zusatzkriteriums weitere Zusatzkriterien zu defi-
nieren.

• Sie können für INTERLIS-Topics keine Zusatzkriterien definieren.

Erzeugen neuer SHP-Objekte
Wählen Sie eine Tabelle oder ein Zusatzkriterium aus. Wählen Sie mit SHP>New den ge-
wünschten Objekttyp aus. Das neue Objekt wird der ausgewählten Tabelle oder dem
ausgewählten Kriterium zugeordnet. Bemerkung: Der Objekttyp Text ist im SHP-
Format nicht direkt vorhanden. Falls Sie Objekte vom Typ Text konfigurieren, werden
diese bei der Übersetzung automatisch in Polylinienobjekte umgewandelt.

Editieren eines SHP-Objekts
Wählen Sie ein SHP-Objekt wie unter 4.2 beschrieben aus. Sie können nun in die einzel-
nen Felder des SHP-Objekts Werte eingeben. Sie haben folgende Möglichkeiten um
Werte einzugeben:

• Im Attribut File muss die SHP-Outputdatei angegeben werden. Diese Angabe ist
für alle SHP-Objekte obligatorisch. Der Name der Ouptutdatei muss ohne Endung
angegeben werden, da später für jedes SHP-Objekt drei Dateien <File>.shp,
<File>.shx und <File>.dbf erzeugt werden. Sie können für jedes SHP-Objekt eine
andere Datei angeben. Es ist jedoch auch möglich mehre SHP-Objekte in der
gleichen Datei zu speichern. Allerdings muss dann der Grundtyp der SHP-Objekte
(Punkt, Polylinie oder Polygon) zusammenpassen. Z.B. ist es nicht möglich ein
Punktobjekt in einer Liniendatei zu speichern.

• Sie können Konstanten von Hand eintragen, z.B. 0.0 für das Attribut Rot
(Textobjekt).

• Sie können Attributnamen als Wert eintragen. Attributnamen können eingetragen
werden, indem Sie den Attributnamen aus dem View INTERLIS Attributes
auf ein Feld des SHP-Objekts ziehen (Mauspfeil über dem Attribut positionieren
und linke Maustaste festhalten und auf das Zielfeld ziehen, Drag and Drop). Ach-
tung: Falls Sie Attributnamen von Hand eintragen, muss der Name mit IN. be-
ginnen damit IL2SHP den Namen von Konstanten unterscheiden kann.
Ausserdem muss der Name ein gültiger Attributname der aktuellen Tabelle sein.
Falsche Eingaben führen zu Fehlermeldungen beim Ausführen des Skripts.

Bemerkungen:

• Beim Ziehen von Attributnamen auf Felder muss darauf geachtet werden, dass der
Typ des Attributs mit dem Feld zusammenpasst (Aufzählungsattribute sollte z.B.
nicht auf Positionsfelder gezogen werden). Falls der Typ des Attributs mit dem
Feld nicht zusammen passt, versucht IL2SHP den Typ automatisch zu wandeln.
Falls der Attribut- und der Feldtyp inkompatibel sind, führt dies zur Laufzeit zu
Fehlermeldungen.

• Felder die mit einem * markiert sind müssen immer ausgefüllt werden. Z.B. muss
das Feld File immer angegeben werden.

• Falls Sie ein GEOM-Attribut aus einem Area-View auf das Geometriefeld eines
Polygonobjekts ziehen, bewirkt dies die automatische Berechnung der
Flächentopologie. Die neu berechneten Objekte enthalten in IN.GEOM die
Flächengeometrie.
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• Falls Sie ein GEOM-Attribut aus einem Boundary-View auf das Geometriefeld eines
Polylineobjekts ziehen, bewirkt dies die automatische Berechnung der
Flächentopologie. Die neu berechneten Objekte enthalten in IN.GEOM die
Geometrie der Begrenzungslinie und in IN.LEFT bzw. in IN.RIGHT einen
Verweis auf das Objekt links bzw. rechts der Linie.

Sachdaten
Falls Sie zu einem SHP-Objekt Sachdaten konfigurieren wollen, müssen Sie zuerst das
SHP-Objekt erzeugen und unmittelbar danach ein Objekt vom Typ Record.

Oben wurde z.B. zuerst ein Polygonobjekt und danach die dazugehörigen Sachdaten
konfiguriert. Die einzelnen Attribute werden wie folgt definiert:

1. Tragen Sie unter Name den Namen des Attributs ein (z.B. ART).

2. Tragen Sie unter Type den Typ des Attributs ein. Folgende Typen werden
unterstützt:

CHAR(<Length>): Zeichenkette mit maximaler Länge <Length>, z.B.
CHAR(80).

NUMBER(<Length>): Ganze Zahl mit maximaler Länge <Length>,
z.B. NUMBER(10).

NUMBER(<Length>.<Decimals>): Reelle Zahl mit maximaler Länge <Length>
(inkl. Dezimalpunkt) und <Decimals> Dezimalen, z.B. NUMBER(10.3).

DATE: Datum. Das Datum muss als Integer in der Form YYYYMMDD übergeben
werden.

3. Tragen Sie unter Value den Wert des Attributs ein. Für den Wert können
Konstanten (z.B. Wiese) oder INTERLIS-Attributnamen (z.B. IN.Art_TXT)
eingetragen werden. Bemerkung: INTERLIS-Attributnamen können auch via Drag
and Drop eingetragen werden.

4. Klicken Sie auf Create.

Mit Update können die Attributdefinitionen editiert und mit Delete auch wieder
gelöscht werden. Dazu muss das entsprechende Attribut zuerst unter Attributes
selektiert werden.

Kopieren von SHP-Objekten
Falls Sie ein bestehendes SHP-Objekt an einen anderen Ort kopieren möchten:

1. Wählen Sie das SHP-Objekt aus.
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2. Selektieren Sie SHP>Copy.

3. Wählen Sie die Tabelle oder das Zusatzkriterium aus wohin das Objekt kopiert
werden soll.

4. Selektieren Sie SHP>Paste.

Löschen von SHP-Objekten
Falls Sie ein bestehendes Objekt löschen wollen:

1. Wählen Sie das SHP-Objekt aus.

2. Selektieren Sie SHP>Delete.

4.5 Setzen von Optionen

INTERLIS-Optionen
Im Menü INTERLIS>Options können folgende Optionen ein- oder ausgeschaltet wer-
den:

LOG_TABLE
Erzeugt für jede gelesene INTERLIS-Tabelle im Logfile ics.log einen Eintrag.

TRACE
Erzeugt für jedes gelesene INTERLIS-Objekt einen Eintrag in der Logdatei.

STATISTICS
Gibt am Ende der Logdatei eine Statistik über alle gelesenen INTERLIS-Objekte
aus.

SHP-Optionen
Im Menü SHP>Set Stroke Tolerance kann die Stroketroleranz angegeben werden
mit der Kreisbogen durch Polyliniensegmente approximiert werden (Default: 0.01).
Ein Kreisbogen wird gleichmässig in Liniensegemente aufgelöst, bis die Toleranz unterschritten
ist.
tolerance > 0.0 :
Die Toleranz ergibt sich aus dem Verhältnis der Pfeilhöhe zum Radius eines Kreisbogens.
tolerance = 0.0:
Der Kreisbogen wird in den Anfangs- und Endpunkt und dem Punkt auf dem Kreisbogen
aufgelöst.
tolerance < 0.0 :
Die Toleranz ist ein absoluter Wert in Meter, der die maximale Pfeilhöhe definiert.
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Bemerkungen:

Die Stroketoleranz beeinflusst die Topolgieberechnung nicht, d.h. die Topologie wird
immer mit Kreisbögen gerechnet. Da das SHP-Format jedoch keine Kreisbögen
unterstützt, müssen Kreisbögen unmittelbar vor dem Schreiben in die Ouputdatei in
Polylinien aufgelöst werden.

Für die SHP-Objekte Polyline und Polygon kann die Stroketoleranz auch lokal
gesetzt werden. Falls für diese Objekte keine lokale Stroketoleranz definiert wurde, gilt
die globale Stroketoleranz.

Im Menü SHP>Options können folgende Optionen ein- oder ausgeschaltet werden:

STATISTICS
Gibt am Ende der Logdatei eine Statistik über alle geschriebenen SHP-Objekte
aus.
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4.6 Speichern der Konfiguration
Falls Sie die von Ihnen veränderte oder erzeugte Konfiguration speichern wollen:

1. Wählen Sie aus dem File-Menü File>Save oder File>Save As .. aus.

2. File>Save sichert die Konfiguration unter dem aktuellen Namen (der aktuelle
Name ist wird in der Titelleiste des Konfigurationseditors eingeblendet).

3. Mit File>Save As .. können Sie einen neuen Namen angeben.

Das Speichern der Konfiguration erzeugt für Sie automatisch ein iG/Script Programm.
Die vom Konfigurationseditor erzeugten Konfigurationen sollten Sie nicht von Hand
editieren. Die neue Konfiguration können Sie mit der ICS-Runtimeumgebung ausführen
(s.a. Kapitel 3).

Hinweis: Konfigurationen werden immer unter ILTOOLS_DIR\user\script\il2shp
gespeichert auch wenn sie ursprünglich aus ILTOOLS_DIR\system\script\il2shp
geladen wurden. Damit wird verhindert, dass Systemkonfigurationen versehentlich
verändert werden.
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5. Fortgeschrittene Konfiguration
Normalerweise werden Sie mit den in Kapitel 4 beschriebenen Möglichkeiten des
Konfigurationseditors auskommen. Es kann jedoch sein, dass Sie auf die Berechnung von
Werten aus bestehenden Attributen angewiesen sind. In diesem Falls steht Ihnen die
ganze Funktionalität der Skriptsprache iG/Script zur Verfügung.

Problem: Im INTERLIS-Modell Grunddatensatz.ili soll für Höhenpunkte ein
Punkt dargestellt und die Höhe als Attribut abgespeichert werden. Die
Höhen ist jedoch in Grunddatensatz.ili nicht direkt sondern nur indirekt
über das Attribut IN.Geometrie (3D-Koordinate) verfügbar.

Lösung: Aus dem Attribut IN.Geometrie wird mit iG/Script ein neues Attribut
IN.Hoehe berechnet und dieses dann als Attributwert benutzt.

Die Umsetzung des obigen Beipiels soll nun in den folgenden Abschnitten erläutert wer-
den. Die Sprache iG/Script ist im Detail in [3] dokumentiert.

5.1 Benutzerprozeduren
Sie können iG/Script Programmcode nicht direkt mit dem Konfigurationseditor eingeben.
Sie müssen iG/Script Prozeduren in der Datei ILTOOLS_DIR\user
\script\il2shp\il2shp.out mit einem Texteditor (z.B. notepad.exe) definieren.
Bemerkung: Falls die Datei noch nicht existiert, können Sie die Datei von
ILTOOLS_DIR\system\script\il2shp\il2shp.out kopieren. Für die Berechnung der
Höhenkote geben Sie z.B. folgende Prozedur ein:

PROCEDURE HOEHE0
IN.Geometrie POINTZ TO_STRING '1' ROUND => IN.Hoehe

END_PROCEDURE

Die Prozedur HOEHE0 berechnet nun aus dem Attribut IN.Geometrie wie gewünscht
das Attribut IN.Hoehe (gerundet auf 1 Nachkommastelle). Sie können die neue Proze-
dur mit dem Konfigurationseditor in Ihre Konfiguration einbauen, indem Sie im Menü
SHP>New>Procedure auswählen und im Feld Procedure Name die neue Prozedur
aus der Werteliste auswählen.
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Wir können nun den Hoehenpunkt fertig konfigurieren. Zuerst wurde die Prozedur
definiert. Danach haben wir den Punkt eingefügt und zuletzt einen Record zum Punkt
definiert. Beachten Sie, dass die Berechnung von IN.Hoehe vor der Benutzung von
IN.Hoehe im Recordobjekt (Feld HOEHE) definiert werden muss. Bemerkung: Das
Attribut IN.Hoehe muss von Hand eintragen werden, da das Attribut erst zur Laufzeit
der ICS-Runtimeumgebung bekannt ist.

5.2 Parameterübergabe
Es ist möglich den Benutzerprozeduren Argumente zu übergeben. Die Benutzerprozedu-
ren müssen für die Abfrage der Parameterwerte folgende Prozeduren verwenden:

GET_PARAM beliebiges Attribut.
GET_IPARAM Integer-Attribut oder Integer-Konstante.
GET_RPARAM Real-Attribut oder Real-Konstante.
GET_SPARAM String-Attribut oder String-Konstante.
GET_PPARAM Punkt-Attribut oder Punkt-Konstante.
GET_LPARAM Linien-Attribut.
GET_APARAM Flaechen-Attribut.

Beispiel:

PROCEDURE HOEHE1 ! Punktgeometrie
GET_PPARAM POINTZ TO_STRING '1' ROUND => IN.Hoehe

END_PROCEDURE

Die Prozedur HOEHE1 berechnet die Hoehe für ein beliebiges Punktattribut. Die neue
Prozedur kann z.B. für die Berechnung der Höhenkote wie folgt benutzt werden:
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6. Konfigurationen im Produkt
Das Produkt beinhaltet bereits Konfigurationen, die Sie Anwenden können. Diese
Konfigurationen werden nachfolgend beschrieben.

6.1 Konfiguration il2shpgen.cfg
Die Konfiguration il2shpgen.cfg übersetzt eine beliebige INTERLIS-Transferdatei in
Shapefiles. Neben dem Transfer der INTERLIS-Transferdatei erstellt die
Konfiguration auch eine IL2SHP-Konfiguration für das in der INTERLIS-
Transferdatei enthaltene INTERLIS-Modell. Diese IL2SHP-Konfiguration können
Sie mit dem Konfigurations-Editor bei Bedarf nachbearbeiten.
Nachfolgend ist die Bedienung der Konfiguration il2shpgen.cfg beschrieben:

1. Aktivieren Sie das Programm über den Windows Start-Knopf (Windows NT 4.0
und Windows 95).

2. Wählen Sie mit Script ... die Konfiguration il2shpgen.cfg  im
Unterverzeichnis il2shp aus.

3. Starten Sie die Konfiguration mittels Run.

4. ICS for Windows fragt Sie zuerst nach der INTERLIS-Inputdatei und dann nach
einer Datei im Shapefile-Outputdirectory ab.
Bemerkung: Falls Sie die Eingabe mit Abbrechen abschliessen, wird auch der
Skript abgebrochen. Weiter mit Schritt 2, 3 oder Cancel.

5. ICS for Windows ermittelt aus der INTERLIS-Inputdatei das INTERLIS-Modell
und bietet in einer Liste alle Themen und Objekte als Topics und Tables zur
Uebersetzung an.
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Selektieren Sie die zu übersetzenden Themen und Objekte und fahren Sie mit OK
weiter.
Bemerkung: Falls Sie die Eingabe mit Cancel abschliessen, wird auch der
Skript abgebrochen. Weiter mit Schritt 2, 3 oder Cancel.

6. ICS for Windows übersetzt nun die Inputdatei in die Outputdateien im Output-
Directory. Fehlermeldungen werden in die Logdatei
ILTOOLS_DIR\temp\ics.log geschrieben.

Zudem wird im Verzeichnis ILTOOLS_DIR\script\il2shp eine IL2SHP-
Konfiguration angelegt.
Diese Konfigurationen erhält als Filenamen den Modellnamen des INTERLIS-
Inputfiles und die Extension cfg .

Beispiel: INTERLIS-Modell: Grunddatensatz
IL2SHP-Konfiguration: Grunddatensatz.cfg

Diese Konfiguration kann mit dem IL2SHP-Konfigurationseditor nachbearbeitet
werden und mit dem IL2SHP-Translator können entsprechend INTERLIS-Daten
nach Shapefiles übersetzt werden.
Für das dazu notwendige Produkt IL2SHP benötigen Sie allerdings eine
entsprechende Lizenz.

7. Sie können die Logdatei nach Beendigung des Skripts mit Show Log anzeigen.

6.2 Konfiguration Grunddatensatz.cfg
Die Konfiguration Grunddatensatz.cfg übersetzt eine INTERLIS-Transferdatei im
AV93-INTERLIS-Modell nach Shapefiles. Die Konfiguration Grunddatensatz.cfg  ist
eine mit dem Konfigurations-Editor erstellte Konfiguration. Die Konfiguration
übersetzt nur ausgewählte Objekte.
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