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1. Einleitung
Das IL2MIF Benutzerhandbuch beschreibt den infoGrips INTERLIS => MIF Translator
Version (kurz IL2MIF). Mit IL2MIF können beliebige INTERLIS 1 Transferdateien in
MapInfo Interchange (MIF) Dateien umgewandelt werden. Der Transfer von INTERLIS
nach MIF kann aus folgenden Gründen notwendig sein:

• Datenübernahme aus der amtlichen Vermessung.

• Datenabgabe von Vermessungsdaten an Dritte (Architekten, Ingenieurbüros, SBB,
PTT).

• Datenübernahme / abgabe von anderen in INTERLIS verfügbaren Datensätzen
(z.B. Leitungskataster SIA 405).

IL2MIF kann sehr flexibel auf die Bedürfnisse des Benutzers konfiguriert werden.
IL2MIF verfügt dazu über folgende Eigenschaften:

• Einen eingebauten INTERLIS-Compiler.

• Automatische Topologieberechnung für AREA- und SURFACE-Typen.

• Volle Programmierbarkteit mit der Skriptsprache iG/Script.

Trotz der Flexibilität bleibt die Konfigurierung von IL2MIF einfach und kann auch von
gelegentlichen Benutzern durchgeführt werden. Dies wird vor allem durch den IL2MIF-
Konfigurationseditor ermöglicht, mit dem IL2MIF-Konfigurationen über eine
Windowsoberfläche editiert werden können. Im Lieferumfang von IL2MIF ist ausserdem
eine Grunddatensatz/MIF- und SIA405/MIF-Konfiguration enthalten, so dass der
Benutzer IL2MIF auch ohne eigenen Konfigurationsaufwand direkt einsetzen kann.

IL2MIF ist ein Bestandteil des Produktes INTERLIS Tools, kann aber auch einzeln
lizenziert werden.

1.1 Allgemeines zu IL2MIF
Die Software IL2MIF besteht aus zwei Teilen:

1. Der ICS-Runtimeumgebung. Mit der Runtimeumgebung können die mit dem
Konfigurationseditor erstellten Konfigurationen mit dem infoGrips Conversion Sy-
stem (ICS) ausgeführt werden. Die Bedienung der ICS-Runtimeumgebung ist in
Kapitel 3 beschrieben.

2. Dem IL2MIF-Konfigurationseditor. Mit dem Konfigurationseditor können neue
Konfigurationen generiert oder bestehende Konfigurationen angepasst werden.
Der Konfigurationseditor ist in Kapitel 4 beschrieben.

In der  folgenden Graphik ist der allgemeine Aufbau der Software schematisch auf der
nächsten Seite dargestellt:

Fehler! Kein Thema angegeben.

1.2 Aufbau des Handbuchs
Das Benutzerhandbuch ist wie folgt aufgebaut:

• In Kapitel 2 wird die Installation von IL2MIF beschrieben.
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• In Kapitel 3 wird die Bedienung der ICS-Runtimeumgebung beschrieben.

• In den Kapiteln 4 ist der IL2MIF-Konfigurationseditor beschrieben.

• In Kaptiel 5 wird auf die fortgeschrittenen Konfigurationsmöglichkeiten mit
iG/Script eingegangen.

• Im Anhang ist das Literaturverzeichnis enthalten.

Konventionen:

fett Definitionen, Funktions- und Produktnamen, Menüeinträge.
courier Eingaben im Betriebssystem oder Dateien.
kursiv Dateinamen.
[1] Verweis auf das Literaturverzeichnis im Anhang.

1.3 Ergänzende Dokumentationen
Das Benutzerhandbuch wird durch folgende Dokumentationen ergänzt:

• INTERLIS Tools Benutzerhandbuch zur Installation und Bedienung der
INTERLIS Tools.

• iG/Script Benutzer- und Referenzhandbuch. Im iG/Script Benutzer und Refe-
renzhandbuch ist die Skriptsprache iG/Script im Detail beschrieben.

• ICS Konfigurationshandbuch. In diesem Handbuch sind alle in einer IL2MIF
Konfiguration zur Verfügung stehenden Prozeduren und Methoden beschrieben.

• INTERLIS ein Daten-Austausch-Mechanismus für Landinformationssysteme.
Beschreibt die Datenmodellierungssprache INTERLIS.

• MapInfo Professional Users Guide, Version 6.5. Beschreibt das MapInfo Data
Interchange Format.
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2. Installation
Der IL2MIF Konfigurationseditor ist ein Bestandteil der INTERLIS Tools und wird mit
den INTERLIS Tools installiert und lizenziert.
Beachten Sie daher die Installationsanleitung im INTERLIS Tools Benutzerhandbuch
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3. Bedienung

3.1 Bedienung mit ICS for Windows
Nachfolgend ist die Bedienung der ICS-Runtimeumgebung mit der Oberfläche ICS for
Windows beschrieben:

1. Aktivieren Sie das Programm über den Windows Start-Knopf mit:

Start > Programme> infoGrips INTERLIS Tools > ICS for Windows

2. Wählen Sie mit System Script ... die von Ihnen gewünschte Konfiguration
im Unterverzeichnis il2mif aus.

3. Starten Sie die Konfiguration mit Run.

4. ICS for Windows fragt Sie zuerst nach der INTERLIS-Inputdatei und dann nach
dem Ordner für die mif-Outputdatei(en) ab.

Bemerkung: Falls Sie die Eingabe mit Abbrechen abschliessen, wird auch der
Skript abgebrochen. Weiter mit Schritt 2, 3 oder Cancel.

5. ICS for Windows übersetzt nun die Inputdatei in die Outputdatei(en).
Fehlermeldungen werden in die Logdatei ILTOOLS_DIR\data\temp\ics.log
geschrieben.

6. Sie können die Logdatei nach Beendigung des Skripts mit Show Log anzeigen.

Während der Übersetzung wird die Anzahl INTERLIS-Inputobjekte und die Anzahl er-
zeugter MIF-Objekte angezeigt. Die Anzahl der Input- und Outputobjekte ist normaler-
weise nicht identisch. Die Anzahl hängt von der gewählten Konfiguration und der Struk-
tur des INTERLIS- bzw. MIF-Datenmodells ab.
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3.2 Bedienung über ein DOS-Fenster
In einem DOS-Fenster kann IL2MIF wie folgt aufgerufen werden:

il2mif <Konfigurationsdatei> <Transferdatei> <MIF-Outputdirectory>

Für <Konfigurationsdatei> geben Sie die IL2MIF-Konfiguration an die Sie
benutzen wollen (z.B. Grunddatensatz.cfg). Für <Transferdatei> geben Sie die zu
übersetzende INTERLIS-Transferdatei und für <MIF-Outputdirectory> das
Outputdirectory, wo die erzeugten MIF-Dateien gespeichert werden sollen, an.

IL2MIF übersetzt darauf die Inputdatei in die Outputdatei(en) und gibt Meldungen und
Fehler auf den Bildschirm bzw. in die Logdatei ics.log aus. Sie können die Logdatei mit
jedem Texteditor anzeigen oder ausdrucken.

Damit Sie IL2MIF von der DOS Kommandozeile aus in einem beliebigen Verzeichnis
starten können, müssen Sie die PATH-Variable um das bin-Verzeichnis von
ICS for Windows erweitern. Die Variable können Sie wie folgt
definieren:

• Öffnen Sie in der Windows-Systemsteuerung:

System>Erweitert>Umgebungsvariablen

• Definieren oder erweitern Sie die Variable PATH als Systemvariable oder
Benutzervariable um den Anteil

c:\iltools\system\bin

 (Annahme: die INTERLIS Tools  wurde unter c:\iltools installiert).

• Melden Sie sich in Ihrem System ab und wieder an, oder starten Sie den PC neu.
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4. IL2MIF-Konfigurationseditor
Mit IL2MIF werden folgende Basiskonfigurationen geliefert:

• Grunddatensatz.cfg. Die Konfiguration Grunddatensatz.cfg ist für das Datenmodell
Grunddatensatz (offizielles Datenmodell der V+D) vorkonfiguriert. Mit dem
Konfigurationseditor kann der Benutzer die mitgelieferte Konfiguration anpassen
oder neue Konfigurationen erstellen.

• il2mif.cfg. Die Konfiguration il2mif.cfg erzeugt aus einem beliebigen INTERLIS-
Transferfile ( itf ) eine generische Konfiguration.

Bemerkung: IL2MIF-Konfigurationen sollten nur mit dem Konfigurationseditor und nie
von Hand editiert werden.

4.1 Starten des Konfigurationseditors
Starten Sie den Konfigurationseditor über den Windows Start-Knopf unter Start >
INTERLIS Tools > IL2MIF Konfigurationseditor. Es erscheint das Hauptmenü des
Konfigurationseditors auf dem Bildschirm:

Der Konfigurationseditor ist nun für das Bearbeiten von Konfigurationen bereit. Der
Konfigurationseditor kann mit File>Exit wieder verlassen werden.

Bemerkung: Der Konfigurationseditor registiert die wichtigsten Benutzeraktionen in der
Logdatei ILTOOLS_DIR\temp\mifedit.log. Die Logdatei kann mit File>Show Log
... angezeigt werden.

4.2 Laden und Anzeigen von Konfigurationen
Wählen Sie mit File>Open User ... oder mit File>Open System ... die
Konfiguration aus die Sie anzeigen wollen. Im View INTERLIS Objects werden alle
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verfügbaren INTERLIS-Topics der aktuellen Konfiguration angezeigt. Falls Sie auf das +
Zeichen neben einem Topic klicken werden alle Tabellen des Topics unterhalb des Topics
dargestellt. Sie können nun auf eine Tabelle klicken. Die Attribute der Tabelle werden im
View Attributes of <Table> dargestellt:

Im View Attributes of <Table> werden neben den Attributnamen auch die Typen
der Attribute dargestellt (z.B. Atttribut Nummer, Typ TEXT). Die Typenbezeichungen
entsprechen den INTERLIS-Bezeichnungen bis auf folgenden Ausnahmen:

TID: Transferidentifikation (nur für Attribut OBJID möglich).
IRANGE: Wertebereich von ganzen Zahlen (z.B. [0 .. 10]).
RRANGE: Wertebereich von reellen Zahlen (z.B. [0.0 .. 1.0]).
ENUM: Aufzählungstyp.

Ausserdem werden folgende spezielle Attribute dargestellt:

OBJID: Dieses Attribut enthält die Transferidentifikation.
GEOM: Linienattribut aus AREA- oder SURFACE-Tabellen.

Z.B. BoFlaeche_Geometrie oder LFPNachführung_Perimeter.
GEOM wird auch für mit dem Topologiemodul berechnete Flächen
angezeigt.

REFID: Beziehungsattribut aus SURFACE-Tabellen.

Falls zu der INTERLIS-Tabelle MIF-Objekte konfiguriert wurden, werden diese im View
MIF Objects dargestellt:

Die Felder der MIF-Objekte sind in die Gruppen Parameters und Attributes unter-
teilt. Die Gruppe Parameters enthält Felder die die geometrische Lage des Objekts
beinflussen (z.B. Pos = Position oder Rot = Rotation). Die Gruppe Attributes enthält
MIF-Darstellungsattribute (z.B. Color etc.). Bei mehreren MIF-Objekten pro Tabelle,

wird nur ein MIF-Objekt auf einmal angezeigt. Sie können die anderen MIF-Objekte
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anzeigen, in dem Sie auf den Reiter des gewünschten Objekts klicken (hier: das Klicken
auf  Text bewirkt die Anzeige des Textobjekts).

Spezielle Darstellungen
Falls auf der linken Seite einer Tabelle ein + Zeichen zu sehen ist, sind zu dieser Tabelle
Zusatzkriterien definiert worden. Sie können die Zusatzkriterien anzeigen, indem Sie auf
das + Zeichen klicken. Es ist möglich, dass in einem Zusatzkriterium weitere Zusatzkri-
terien definiert wurden (in diesem Fall steht links des Zusatzkriteriums ein + Zeichen).

Falls neben einem Attribut im Attributview ein + Zeichen steht, handelt es sich bei dem
Attribut um ein Beziehungsattribut. Falls Sie auf das + Zeichen klicken, werden die
Attribute der referenzierten Tabelle angezeigt (hier: Beziehungsattribut Entstehung
mit Attributen aus der referenzierten Tabelle LFPNachführung).

4.3 Erzeugen von neuen Konfigurationen
So erstellen Sie eine neue Konfiguration:

1. Wählen Sie File>New ...

2. Im Untermenü wählen Sie zuerst das INTERLIS-Model aus (.ili). Bemerkung: Das
Modell kann entweder aus ILTOOLS_DIR\user\models (User ...) oder
ILTOOLS_DIR\system\models (System ...) ausgewählt werden.

3. Mit OK wird die neue Konfiguration für Sie erstellt (noname.cfg). Die Konfigura-
tion kann nun wie unter 4.4 beschrieben, editiert werden.

4.4 Ändern einer Konfiguration

Definieren von Zusatzkriterien
Falls Sie Objekte aus der gleichen INTERLIS-Tabelle in MapInfo unterschiedlich
darstellen möchten, müssen Sie Zusatzkriterien für die Tabelle definieren. So definieren
Sie Zusatzkriterien:

1. Wählen Sie die Tabelle aus.
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2. Wählen Sie aus ein Attribut vom Typ ENUM aus.

3. Klicken Sie auf INTERLIS>New Condition.

4. Der Konfigurationseditor fügt darauf alle möglichen Werte des Aufzählungsattri-
buts als neue Zusatzkriterien ein.

Bemerkungen:
• Zusatzkriterien könnnen mit INTERLIS>Delete Condition gelöscht werden.

• Es ist möglich innerhalb eines Zusatzkriteriums weitere Zusatzkriterien zu defi-
nieren.

• Sie können für INTERLIS-Topics keine Zusatzkriterien definieren.

Erzeugen neuer MIF-Objekte
Wählen Sie eine Tabelle oder ein Zusatzkriterium aus. Wählen Sie mit MIF>New den ge-
wünschten Objekttyp aus. Das neue Objekt wird der ausgewählten Tabelle oder dem
ausgewählten Kriterium zugeordnet.

Editieren eines MIF-Objekts
Wählen Sie ein MIF-Objekt wie unter 4.2 beschrieben aus. Sie können nun in die einzel-
nen Felder des MIF-Objekts Werte eingeben. Sie haben folgende Möglichkeiten um Werte
einzugeben:

• Sie können Konstanten von Hand eintragen, z.B. 1.0 für das Attribut Size.

• Sie können Attributnamen als Wert eintragen. Attributnamen können eingetragen
werden, indem Sie den Attributnamen aus dem View INTERLIS Attributes
auf ein Feld des MIF-Objekts ziehen (Mauspfeil über dem Attribut positionieren
und linke Maustaste festhalten und auf das Zielfeld ziehen, Drag and Drop). Ach-
tung: Falls Sie Attributnamen von Hand eintragen, muss der Name mit IN. be-
ginnen damit IL2MIF den Namen von Konstanten unterscheiden kann.
Ausserdem muss der Name ein gültiger Attributname der aktuellen Tabelle sein.
Falsche Eingaben führen zu Fehlermeldungen beim Ausführen des Skripts.

Bemerkungen:

• Beim Ziehen von Attributnamen auf Felder muss darauf geachtet werden, dass der
Typ des Attributs mit dem Feld zusammenpasst (z.B. Aufzählungsattribute sollte
nicht auf Positionsfelder gezogen werden). Falls der Typ des Attributs mit dem
Feld nicht zusammen passt, versucht IL2MIF den Typ automatisch zu wandeln.
Falls der Attribut- und der Feldtyp inkompatibel sind, führt dies zur Laufzeit zu
Fehlermeldungen.

• Felder die mit einem * markiert sind müssen immer ausgefüllt werden. Z.B.
müssen bei POINT Objekten die Felder SHAPE, COLOR und SIZE immer
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angegeben werden.

• Falls Sie ein AREA-Attribut auf das Geometriefeld eines Linien- oder
Polylinienobjektes ziehen, bewirkt dies die automatische Berechnung der
Flächentopologie.

Kopieren von MIF-Objekten
Falls Sie ein bestehendes MIF-Objekt an einen anderen Ort kopieren möchten:

1. Wählen Sie das MIF-Objekt aus.

2. Selektieren Sie MIF>Copy.

3. Wählen Sie die Tabelle oder das Zusatzkriterium aus wohin das Objekt kopiert
werden soll.

4. Selektieren Sie MIF>Paste.

Löschen von MIF-Objekten
Falls Sie ein bestehendes Objekt löschen wollen:

1. Wählen Sie das MIF-Objekt aus.

2. Selektieren Sie MIF>Delete.

4.5 Setzen von Optionen

INTERLIS-Optionen
Im Menü INTERLIS>Options können folgende Optionen ein- oder ausgeschaltet wer-
den:

LOG_TABLE
Erzeugt für jede gelesene INTERLIS-Tabelle im Logfile ics.log einen Eintrag.

TRACE
Erzeugt für jedes gelesene INTERLIS-Objekt einen Eintrag in der Logdatei.

STATISTICS
Gibt am Ende der Logdatei eine Statistik über alle gelesenen INTERLIS-Objekte
aus.

MIF-Optionen
Im Menü MIF>Options können folgende Optionen ein- oder ausgeschaltet werden:

STATISTICS
Gibt am Ende der Logdatei eine Statistik über alle geschriebenen MIF-Objekte
aus.

4.6 Speichern der Konfiguration
Falls Sie die von Ihnen veränderte oder erzeugte Konfiguration speichern wollen:

1. Wählen Sie aus dem File-Menü File>Save oder File>Save As .. aus.
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2. File>Save sichert die Konfiguration unter dem aktuellen Namen (der aktuelle
Name ist wird in der Titelleiste des Konfigurationseditors eingeblendet).

3. Mit File>Save As .. können Sie einen neuen Namen angeben.

Das Speichern der Konfiguration erzeugt für Sie automatisch ein iG/Script Programm.
Die vom Konfigurationseditor erzeugten Konfigurationen sollten Sie nicht von Hand
editieren. Die neue Konfiguration können Sie mit der ICS-Runtimeumgebung ausführen
(s.a. Kapitel 3).

Hinweis: Konfigurationen werden immer unter ILTOOLS_DIR\user\script\il2mif
gespeichert auch wenn sie ursprünglich aus ILTOOLS_DIR\system\script\il2mif
geladen wurden. Damit wird verhindert, dass Systemkonfigurationen versehentlich
verändert werden.
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5. Fortgeschrittene Konfiguration
Normalerweise werden Sie mit den in Kapitel 4 beschriebenen Möglichkeiten des
Konfigurationseditors auskommen. Es kann jedoch sein, dass Sie auf die Berechnung von
Werten aus bestehenden Attributen angewiesen sind. In diesem Falls steht Ihnen die
ganze Funktionalität der Skriptsprache iG/Script zur Verfügung.

Problem: Im INTERLIS-Modell Grunddatensatz.ili soll für Höhenpunkte ein
Punkt dargestellt und die Höhenkote angeschrieben werden. Die
Höhenekote ist jedoch in Grunddatensatz.ili nicht direkt sondern nur
indirekt über das Attribut IN.Geometrie (3D-Koordinate)
verfügbar.

Lösung: Aus dem Attribut IN.Geometrie wird mit iG/Script ein neues Attri-
but IN.Hoehe berechnet und dieses dann für die Darstellung be-
nutzt.

Die Umsetzung des obigen Beipiels soll nun in den folgenden Abschnitten erläutert wer-
den. Die Sprache iG/Script ist im Detail in dokumentiert.

5.1 Benutzerprozeduren
Sie können iG/Script Programmcode nicht direkt mit dem Konfigurationseditor eingeben.
Sie müssen iG/Script Prozeduren in der Datei ILTOOLS_DIR\user
\script\il2mif\il2mif.out mit einem Texteditor (z.B. notepad.exe) definieren.
Bemerkung: Falls die Datei noch nicht existiert können Sie die Datei von
ILTOOLS_DIR\system\script\il2mif\il2mif.out kopieren. Für die Berechnung der
Höhenkote geben Sie z.B. folgende Prozedur ein:

PROCEDURE HOEHE
IN.Geometrie POINTZ TO_STRING '1' ROUND => IN.Hoehe

END_PROCEDURE

Die Prozedur HOEHE berechnet nun aus dem Attribut IN.Geometrie wie gewünscht
das Attribut IN.Hoehe (gerundet auf 1 Nachkommastelle). Sie können die neue Proze-
dur mit dem Konfigurationseditor in Ihre Konfiguration einbauen, indem Sie im Menü
MIF>New>Procedure auswählen und im Feld Prozedur Name die neue Prozedur aus
der Werteliste auswählen.
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Wir können nun den Hoehenpunkt fertig konfigurieren. Zuerst wurde der Punkt
definiert. Danach haben wir die Prozedur eingefügt und zuletzt die Hoehenkote als Text
plaziert.. Beachten Sie, dass die Berechnung von IN.Hoehe vor der Benutzung von
IN.Hoehe im Textobjekt (Feld Txt) definiert werden muss. Bemerkung: Das Attribut
IN.Hoehe müssen Sie im Textobjekt (Feld Txt) von Hand eintragen, da das Attribut
erst zur Laufzeit der ICS-Runtimeumgebung bekannt ist.

5.2 Parameterübergabe
Es ist möglich den Benutzerprozeduren Argumente zu übergeben. Die Benutzerprozedu-
ren müssen für die Abfrage der Parameterwerte folgende Prozeduren verwenden:

GET_PARAM beliebiges Attribut.
GET_IPARAM Integer-Attribut oder Integer-Konstante.
GET_RPARAM Real-Attribut oder Real-Konstante.
GET_SPARAM String-Attribut oder String-Konstante.
GET_PPARAM Punkt-Attribut oder Punkt-Konstante.

Beispiel:

PROCEDURE HOEHE2 ! Punktgeometrie
GET_PPARAM POINTZ TO_STRING '1' ROUND => IN.Hoehe

END_PROCEDURE

Die Prozedur HOEHE2 berechnet die Hoehe für ein beliebiges Punktattribut. Die
neue Prozedur kann z.B. für die Berechnung der Höhenkote wie folgt benutzt
werden:
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