
INTERLIS Tools IL2DB
Konfigurationseditor
Benutzerhandbuch

Zusammenfassung

Diese Dokumentation beschreibt die Bedienung des INTERLIS Tools IL2DB
Konfigurationseditors - INTERLIS nach Datenbank.

31.01.2025Copyright © infoGrips GmbH, 2025

Tel.: 044 / 350 10 10
Fax.: 044 / 350 10 19

Technoparkstrasse 1
8005 Zürich



Die Dokumentation darf nur mit Erlaubnis der infoGrips GmbH vervielfältigt
werden.

Copyright © infoGrips GmbH, 2025Seite 2

INTERLIS Tools IL2DB Konfigurationseditor Benutzerhandbuch, 31.01.2025



Inhaltsverzeichnis
1. Einleitung ....................................................................................................................... 4

1.1. Allgemeines .......................................................................................................... 4
1.2. Architekur ............................................................................................................ 4
1.3. Aufbau dieser Dokumentation .............................................................................. 5
1.4. Ergänzende Dokumentationen ............................................................................. 5
1.5. Konventionen ....................................................................................................... 6

2. Installation ..................................................................................................................... 7
3. Bedienung ICS ................................................................................................................ 8

3.1. Bedienung mit ICS for Windows ........................................................................... 8
3.2. Bedienung über ein DOS-Fenster ......................................................................... 9

4. Bedienung IL2DB Konfigurationseditor ........................................................................ 10
4.1. Starten des Konfigurationseditors ...................................................................... 10
4.2. Verwalten von Konfigurationen .......................................................................... 11

4.2.1. Laden einer bestehenden Konfiguration ................................................... 11
4.2.2. Erzeugen einer neuen Konfiguration ........................................................ 12
4.2.3. Speichern einer Konfiguration ................................................................. 14
4.2.4. Generieren einer Konfiguration ............................................................... 15

4.3. Bearbeiten einer Konfiguration .......................................................................... 15
4.3.1. Übersicht ................................................................................................. 15
4.3.2. Datenbank Record erzeugen .................................................................... 17
4.3.3. Datenbank Record löschen ....................................................................... 19
4.3.4. Datenbank Record kopieren und einfügen ................................................ 19
4.3.5. Konditionen ............................................................................................. 20
4.3.6. Prozeduren .............................................................................................. 21
4.3.7. Optionen .................................................................................................. 23
4.3.8. Parameter Module ................................................................................... 24

A. Literaturverzeichnis ..................................................................................................... 24
B. Begriffe ......................................................................................................................... 24

Seite 3Copyright © infoGrips GmbH, 2025

INTERLIS Tools IL2DB Konfigurationseditor Benutzerhandbuch, 31.01.2025



1. Einleitung

1.1. Allgemeines
Dieses Benutzerhandbuch beschreibt den infoGrips INTERLIS Tools IL2DBKonfigurations-
editor. Unter dem Begriff IL2DB - INTERLIS 1 nach Datenbank - sind alle Datenschnitt-
stellen der INTERLIS Tools zu verstehen, die INTERLIS Daten in ein Datenbanksystem
transferieren. Die INTERLIS Tools unterstützen diverse Datenbanksysteme. IL2DB kann sehr
flexibel auf die Bedürfnisse des Benutzers konfiguriert werden. IL2DB verfügt dazu über fol-
gende Eigenschaften:

• Einen eingebauten INTERLIS-Compiler.

• Automatische Topologieberechnung für AREA- und SURFACE-Typen.

• Volle Programmierbarkteit mit der Skriptsprache iG/Script.

• Konfigurationen generieren das Datenbankmodell (optional).

Trotz der Flexibilität bleibt die Konfigurierung von IL2DB einfach und kann auch von gelegent-
lichen Benutzern durchgeführt werden. Dies wird vor allem durch den IL2DB-Konfigurations-
editor ermöglicht, mit dem IL2DB-Konfigurationen über eine Windowsoberfläche editiert
werden können. Im Lieferumfang von IL2DB sind ausserdem generische Konfiguration enthal-
ten, die für beliebige INTERLISModelle IL2DB-Konfigurationen generieren. Diese generierten
Konfigurationen können direkt eingesetzt werden, oder mit dem IL2DB-Konfigurationseditor
nachbearbeitet werden.

IL2DB unterstützt folgende Datenbanksystem.

• ODBC

• Microsoft Excel

• Microsoft Access

• Oracle Spatial

• Intergraph GeoMedia Access

• Intergraph GeoMedia Oracle

• ESRI Geodatabase Access

• ESRI SDE Oracle

• MySQL

• PostGres/PostGIS

IL2DB ist ein Bestandteil des Produktes INTERLIS Tools, kann aber auch einzeln lizenziert
werden.

1.2. Architekur
IL2DB besteht aus folgenden Teilen:
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1. Der ICS-Runtimeumgebung. Mit der Runtimeumgebung können die mit dem Konfigu-
rationseditor erstellten Konfigurationen mit dem infoGrips Conversion System (ICS)
ausgeführt werden. Die Bedienung der ICS-Runtimeumgebung ist in Kapitel 3 beschrieben.

2. Dem IL2DB Konfigurationseditor. Mit dem Konfigurationseditor können neue Konfi-
gurationen generiert oder bestehende Konfigurationen angepasst werden. Der Konfigura-
tionseditor ist in Kapitel 4 beschrieben.

In der folgenden Graphik ist der allgemeine Aufbau der ICS-Runtimeumgebung dargestellt:

Abbildung 1. Architektur

Mit dem IL2DB Konfugurationseditor werden die Konfigurationen bearbeitet, die dann mit
der ICS-Runtimeumgebung ausgeführt werden.

1.3. Aufbau dieser Dokumentation
Diese Dokumentation ist wie folgt aufgebaut:

• Kapitel 2: Installation.

• Kapitel 3: Bedienung der ICS-Runtimeumgebung.

• Kapitel 4: Bedienung des IL2DB-Konfigurationseditors.

• Anhang: Literatur und Begriffe.

1.4. Ergänzende Dokumentationen
Das Benutzerhandbuch wird durch folgende Dokumentationen ergänzt:

• INTERLIS Tools Benutzerhandbuch zur Installation und Bedienung der INTERLIS Tools.

• iG/Script Benutzer- und Referenzhandbuch. In diesem Handbuch ist die Skriptsprache
iG/Script im Detail beschrieben.
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• ICS Konfigurationshandbuch. In diesem Handbuch sind alle in einer IL2DB Konfiguration
zur Verfügung stehenden Prozeduren und Methoden beschrieben. Zu beachten sind inbe-
sondere die Datenbank Ouput Module.

• INTERLIS ein Daten-Austausch-Mechanismus für Landinformationssysteme. Beschreibt
die Datenmodellierungssprache INTERLIS.

• Spezifische Datenbank Dokumentationen des jeweiligen Datenbank Herstellers.

1.5. Konventionen
In dieser Dokumentation werden folgende Konventionen eingehalten:

Namen von Dateien und URL'sKursiv

neue Begriffe, Namen von Funktionen oder Methodenfett
Programmtext oder Eingaben im Betriebssystemcourier
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2. Installation
Der IL2DB Konfigurationseditor ist ein Bestandteil der INTERLIS Tools und wird mit den
INTERLIS Tools installiert und lizenziert.

Beachten Sie daher die Installationsanleitung im INTERLIS Tools Benutzerhandbuch.
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3. Bedienung ICS

3.1. Bedienung mit ICS for Windows
Nachfolgend ist die Bedienung der ICS-Runtimeumgebung mit der Oberfläche ICS for Win-
dows beschrieben:

1. Aktivieren Sie das Programm über den Windows Start-Knopf mit:

Start > Programme > infoGrips INTERLIS Tools > ICS for Windows

Abbildung 2. ICS for Windows

2. Wählen Sie mit System Script ... oder User Script ... eine gewünschte INTERLIS zu
Datenbank Konfiguration.

INTERLIS zu Datenbank Konfigurationen finden Sie in folgenden System-Script oder
User-Script Unterverzeichnissen.

INTERLIS Tools Lizenz:

ODBC DatenbankenIL2DB

Access Datenbanken.IL2MDB

Excel Datenbanken.ILXLS

GeoMedia Access Datenbanken.IL2GMMDB

ESRI Geodatabase Access Datenbanken.IL2GDB

MySQL Datenbanken.IL2MYSQL

PostGres Datenbanken.IL2PGRES

INTERLIS Tools Professional Lizenz:

GeoMedia Oracle Datenbanken.IL2GMORA

Oracle Datenbanken.IL2ORA
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INTERLIS Tools for SDE Lizenz:

ESRI SDE Datenbanken.IL2SDE

Je nach Datenbanksystem müssen Sie eventuell vor der Ausführung der Konfiguration die
Datenbank anlegen und eine ODBC-Quelle unter Windows definieren (zum Beispiel Oracle).☞

3. Starten Sie die Konfiguration mit Run .

4. ICS for Windows fragt die INTERLIS-Inputdatei und die Output-Datenbank ab.

Falls Sie die Eingabe mit Abbrechen abschliessen, wird auch der Skript abgebrochen. Weiter
mit Schritt 2, 3 oder Cancel.☞

5. ICS forWindows übersetzt nun die Inputdatei in die Datenbank . Fehlermeldungenwerden
in die Logdatei ILTOOLS_DIR\data\temp\ics.log geschrieben. Bei Bedarf wird auch das
Datebankmodell (Tables) angelegt.

6. Sie können die Logdatei nach Beendigung des Skripts mit Show Log anzeigen. Mit
Cancel verlassen Sie das Programm.

Während derÜbersetzungwird die Anzahl INTERLIS-Inputobjekte und die Anzahl Datenbank-
Outputobjekte angezeigt. Die Anzahl der Input- und Outputobjekte ist normalerweise nicht
identisch. Die Anzahl hängt von der gewählten Konfiguration und der Struktur des INTERLIS-
beziehungsweise dem Datenbankmodelles ab.

Jedes Datenbanksystem besitzt bestimmte Eigenschaften. Solche Eigenschaften können über die
Parameter des entsprechenden Datenbank Output Modules gesteuert werden. Beachten Sie dazu
die Dokumentation des Datenbank Output Modules im ICS Konfigurationshandbuch.

☞

3.2. Bedienung über ein DOS-Fenster
Für die Batchanwendung von ICS Konfigurationen beachten Sie bitte das enstprechende Ka-
pitel im INTERLIS Tools Benutzerhandbuch.
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4. Bedienung IL2DBKonfigurations-
editor

4.1. Starten des Konfigurationseditors
Aktivieren Sie das Programm über den Windows Start-Knopf mit:

Start > Programme > infoGrips INTERLIS Tools > IL2DB Konfigurationseditor

Abbildung 3. IL2DB Konfigurationseditor

Der Konfigurationseditor ist nun für das Bearbeiten von Konfigurationen bereit. Der Konfigu-
rationseditor kann mit File > Exit wieder verlassen werden.

Der Konfigurationseditor registiert die wichtigsten Benutzeraktionen in der Logdatei IL-
TOOLS_DIR\temp\shpedit.log. Die Logdatei kann mit File > Show Log ... angezeigt werden.☞
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4.2. Verwalten von Konfigurationen

4.2.1. Laden einer bestehenden Konfiguration
Eine bestehende Konfiguration wird wie folgt geöffnet:

1. Wählen Sie File > Open

2. Folgendes Menü erscheint:

Abbildung 4. Bestehende Konfiguration Datenbanktyp und
Konfiguration wählen

3. Wählen Sie mit DB Type den gewünschten Datenbanktyp.

4. Selektieren Sie mitUser ... oder System ... die gewünschte Konfiguration für den Daten-
banktyp.

5. Akzeptieren Sie Ihre Eingaben mit Ok oder verlassen Sie das Menü mit Cancel .

6. Falls Sie die Eingabe mit Ok akzeptiert haben, wird die Konfiguration geladen und ange-
zeigt.
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Abbildung 5. KonfigurationAnzeigeModell undDatenbankRecords

Die Konfiguration kann nun gesichtet und/oder bearbeitet werden - siehe weiteres Kapitel.

4.2.2. Erzeugen einer neuen Konfiguration
Eine neue Konfiguration wird wie folgt kreiert:

1. Wählen Sie File > New

2. Folgendes Menü erscheint:
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Abbildung 6. NeueKonfigurationDatenbanktyp undKonfiguration
wählen

3. Wählen Sie mit DB Type den gewünschten Datenbanktyp.

4. Selektieren Sie mit User ... oder System ... das gewünschte INTERLIS Modell für die
Konfiguration.

5. Akzeptieren Sie Ihre Eingaben mit Ok oder verlassen Sie das Menü mit Cancel .

6. Falls Sie die Eingabe mit Ok akzeptiert haben, wird das Modell geladen und angezeigt.
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Abbildung 7. Konfiguration Anzeige Modell

Die Konfiguration kann nun gesichtet und/oder bearbeitet werden - siehe weiteres Kapitel.

4.2.3. Speichern einer Konfiguration
Eine neue oder bestehende und bearbeitete Konfiguration wird wie folgt gespeichert:

1. Mit File > Save

wird eine bestehende Konfiguration unter dem bestehenden Namen abgespeichert.

Falls es sich um eine neue Konfiguration handelt, wird wie bei File > Save as ... ein Konfi-
gurationsnamen abgefragt.

2. Mit File > Save as ...

wird eine neue oder bestehende Konfiguration unter einem neuen Namen abgespeichert.

Folgendes Menü erscheint.
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Abbildung 8. Konfiguration speichern

3. Geben Sie einen neuen Namen für die Konfiguration ein oder selektieren Sie eine beste-
hende Konfiguration, die Sie überschreiben wollen.

Mit Speichern speichern Sie die Konfiguration. Mit Abbrechen brechen Sie die Aktion
ab.

Von Ihnen erzeugte oder geänderte Konfigurationen werden per Default immer im User-Ast der
INTERLIS Tools abgelegt.Wenn Sie urprünglich eine Konfiguration aus demSystem-Ast geladen☞
haben, und diese wieder speichern, so wird die Konfiguration im analogen Directory im User-Ast
abgespeichert.

4.2.4. Generieren einer Konfiguration
INTERLIS nach Datenbank Konfigurationen können Sie mit den INTERLIS Tools generieren
und direkt anwenden oder mit dem Konfigurationseditor nachbearbeiten.

Pro Datenbanksystem finden Sie in den INTERLIS Tools einen entsprechenden Generator.
Beachten Sie dazu das INTERLIS Tools Benutzerhandbuch.

Zum Beispiel ist unter

c:\iltools\system\script\il2ora\il2oragen.cfg

der Konfigurationsgenerator für eine Datentransfer INTERLIS nach Oracle Spatial enthalten.

Wenden Sie diesen Generator mit ICS for Windows an. Es wird eine Konfiguration generiert.

4.3. Bearbeiten einer Konfiguration

4.3.1. Übersicht
Der Konfigurationseditor beinhaltet folgende Anteile.
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Abbildung 9. Konfigurationseditor Anteile

INTERLIS Objects
Hier werden die INTERLIS Objekte in der Hierarchie Topics > Tables aufgelistet.
Wenn Sie eine Topic anklicken, werden die Tables der Topic dargestellt.

Attributes of <Table>
Wenn Sie unter INTERLIS Objects eine Table anklicken, so werden hier die Attribute
der INTERLIS Table angezeigt.

Neben den Attributnamen werden auch die Typen der Attribute dargestellt (z.B. Att-
tribut Nummer, Typ TEXT). Die Typenbezeichungen entsprechen den INTERLIS-Be-
zeichnungen bis auf folgenden Ausnahmen:

TID
Transferidentifikation (nur für Attribut OBJID möglich).

IRANGE
Wertebereich von ganzen Zahlen (z.B. [0 .. 10]).

RRANGE
Wertebereich von reellen Zahlen (z.B. [0.0 .. 1.0]).
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ENUM
Aufzählungstyp.

Ausserdem werden folgende spezielle Attribute dargestellt:

OBJID
Dieses Attribut enthält die Transferidentifikation.

GEOM
Linienattribut aus AREA- oder SURFACE-Tabellen.

z.B. BoFlaeche_Geometrie oder LFPNachführung_Perimeter

REFID
Beziehungsattribut aus SURFACE-Tabellen.

<Attribute>_TXT
Textwert eines Attributes mit einem Aufzählungstyp - ENUM.

DB Objects
Hier werden die Datenbankobjekte (Tables) in Abhängigkeit der INTERLIS Objekte
definiert. Die Definition umfasst die Definition eines Records mit dem Tabellennamen
und den Attributen mit ihren Namen, Typen und Werten.

4.3.2. Datenbank Record erzeugen
Einen Datenbank Record definieren Sie wie folgt:

1. Selektieren Sie eine INTERLIS Topic und eine INTERLIS Table für welche Sie einen Da-
tenbank Record definieren möchten.

2. Wählen Sie DB > New > Record
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Abbildung 10. Datenbank Record definieren

3. Geben unter Table einen Tabellennamen für die Datenbank ein.

4. Definieren Sie unter Attribute mitName, Type und Value ein Attribut und kreieren Sie
das Attribut mit Create.

Beachten Sie dabei folgendes.

Name
Der Attributname muss ein für das gewählte Datenbanksystem gültiger Namen
sein. Verwenden Sie für die Namen also zumBeispiel keine vomDatenbanksystem
reservierten Namen.

Type
Der Attributtyp muss ein vom Datenbanksystem unterstützter Typ sein. In der
Auswahlliste des Typs sind einige vordefiniert Typen für das ausgewählte Daten-
banksystem aufgeführt. Sie können aber auch andere, dem ausgewählten Daten-
banksystem bekannte Typen, definieren.

Bei den vordefinierten Typen ist folgendes zu beachten.
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CHAR(l)
Der Type CHARmit der Länge <l> wird in ein dem gewählten Datenbank-
system entsprechenden Charactertype umgesetzt.

Zum Beispiel Oracle in VARCHAR(<l>).

SMALLINT, INEGER, NUMBER, NUMBER(<l>), NUMBER(<l>,<p>)
Diese Zahlentypen werden direkt oder in ein dem gewählten Datenbank-
system entsprechenden Typ umgesetzt.

<Prefix>GEOMETRY
Geometrytypen benötigen in der Regel pro Datenbanksystem weiterer
Parameter. In der Regel sind die möglichen Parameter in den aufgelisteten
Geometrietypen aufgeführt. Für weitere Details beachten Sie bitte die
Beschreibung des jeweiligen Output Modules für ein Datenbanksystem
im ICS Konfigurationshandbuch.

Value
Der Wert ergibt sich in der Regel aus einem INTERLIS Attribut. Selektieren Sie
ein INTERLIS Attribut und ziehen Sie dieses in das Value-Feld. Beachten Sie,
dass der Typ des Wertes mit dem Attribut Type der Record-Definition kompatibel
sein muss.

5. Wiederholen Sie den 4. Schritt für alle Attribute, die Sie übertragen möchten.

6. Mit Delete können Sie das aktuelle Attribut löschen.

7. Mit Update können Sie den Type und/oder Value des aktuellen Attributes updaten.

8. Selektieren Sie weitere INTERLIS Tables und definieren Sie die Records dazu.

Sie können pro INTERLIS Objekt mehrere Records definieren, zum Beispiel einen Record mit
allen Attributen und einen Record mit den wichtigsten Attributen.

Eventuell möchten Sie für ein Attribut der Datenbank einen anderen Basistyp verwenden, als
der Basistyp des Attributes in INTERLIS. Zum Beispiel eine INTERLIS-Zahl in einen Daten-
bank-Text umwandeln. Diese Typumwandlungmüssen Sie über eine Prozedur bewerkstelligen.
Siehe dazu das Kapitel mit den Prozeduren.

4.3.3. Datenbank Record löschen
Um eine Record Definition zu löschen, gehen Sie wie folgt vor.

1. Selektieren Sie über INTERLIS-Topics und INTERLIS-Table das INTERLIS Objekt.

2. Selektieren Sie den Record.

3. Mit DB > Delete wird der aktuelle Record gelöscht.

4.3.4. Datenbank Record kopieren und einfügen
Um eine Record Definition zu kopieren, gehen Sie wie folgt vor.

1. Selektieren Sie über INTERLIS-Topics und INTERLIS-Table das INTERLIS Objekt mit
dem zu kopierenden Record.

2. Selektieren Sie den Record.
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3. Mit DB > Copy wird der aktuelle Record kopiert.

4. Selektieren Sie über INTERLIS-Topics und INTERLIS-Table das INTERLIS Objekt zu
dem Sie den Record kopieren möchten.

5. Mit DB > Paste wird der Record eingefügt.

6. Passen Sie den Record für das neue INTERLIS Objekt bei Bedarf an.

4.3.5. Konditionen
Über INTERLIS Aufzählungstypen - ENUM - können Konditionen definiert werden, die ein
Fallunterscheidung unterstützen, zumBeispiel das Schreiben in unterschiedliche Datenbank-
tabellen.

Zu Definition einer Kondition gehen Sie wie folgt vor.

1. Selektieren Sie über INTERLIS-Topics und INTERLIS-Table das INTERLIS Objekt.

2. Selektieren Sie das INTERLIS Attribut mit dem Aufzählungstyp ENUM.

3. Mit INTERLIS > New Condition wird die Kondition generiert.

Bei den INTERLIS Objekten wird eine Unterscheidung nach den Aufzählungswerten
aufgeführt.

Pro Wert können Sie separate Record Definitionen vornehmen.
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Abbildung 11. Kondition

4. Mit INTERLIS > Delete Condition können Sie einzelne Konditionen wieder entfernen.

4.3.6. Prozeduren
Bei Datentransfers sind ab und zu Berechnungen notwendig. Solche Berechnungen - z.B. ein
neues Attribut in Abhängigkeit anderer Attribute erzeugen - wird über Prozeduren durchgeführt.
Einige häufig benötigte Prozeduren sind bereits vordefiniert. Sie können aber auch eigene
Prozeduren definieren.

Eine bestehende Prozedur wird wie folgt mit dem Konfigurationseditor eingefügt.

1. Selektieren Sie über INTERLIS-Topics und INTERLIS-Table das INTERLIS Objekt.

2. Mit DB > New Procedure wird eine Definition für eine Prozedur aktiviert.
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Abbildung 12. Prozedur

3. Selektieren Sie unter Procedure Name die gewünschte Prozedur.

4. Prozeduren benötigen eventuell Parameter. Geben Sie für die Prozedur notwendigen die
Parameter in den Feldern Parameter 1 bis Parameter 6 ein.

Die Prozedur berechnet unter umständen ein neues Attribut, das Sie in einer weiteren
Record Definition verwenden können.

Beispiel oben CALC_AREA1:

Das Beispiel CALC_AREA1 erwartet als Parameter eine Fläche. Für die Fläche wird in
der Prozedur die Flächengrösse berechnet und im Attribut IN.Area abgelegt. Das Attribut
IN.Area kann nun in einer Record Definitionen als Attribut für die Datenbank verwendet
werden.

5. MitDB>Delete,DB>Copy undDB>Paste können Sie eine Prozedur wie einen Record
löschen, kopieren und einfügen.

Eigene, neue Prozeduren definieren Sie wie folgt.
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1. Falls die Konfigurationmit demKonfigurationseditor geöffnet ist, sichern Sie die Konfigu-
ration.

Zum Beispiel die Konfiguration

c:\iltools\user\script\il2ora\DM01AVCH24D.cfg

2. Kreieren Sie mit einem Texteditor ein OUT-Textfile im selben Verzeichnis wie die Konfi-
guration.

Zum Beispiel das OUT-Texfile

c:\iltools\user\script\il2ora\DM01AVCH24D.out

3. Fügen Sie in dem OUT-Textfile die gewünschte Prozedur ein:

c:\iltools\user\script\il2ora\DM01AVCH24D.out

PROCEDURE CALC_AREA1 ! area
   GET_APARAM GET_AREA => IN.Area
END_PROCEDURE

Schliessen und sichern Sie das File.

4. Inkludieren Sie das OUT-Textfile in der Konfiguration mit einem Texteditor:

c:\iltools\user\script\il2ora\DM01AVCH24D.cfg

:
|INCL \script\il2ora\il2ora.out
|INCL \script\il2ora\DM01AVCH24D.out
|INCL \script\run1.prg

Schliessen und sichern Sie die Konfiguration.

5. Laden Sie die Konfiguration in den Konfigurationseditor.

Die Prozedur steht nun zur Auswahl zur Verfügung.

Mehr zur Scriptsprache iG/Script mit der Prozeduren geschrieben werden, finden Sie im
iG/Script Benutzer- und Referenzhandbuch.

Mehr zu Konfigurationen finden Sie im ICS Konfigurationshandbuch.

4.3.7. Optionen
Folgende weitere Optionen können mit dem Konfigurationseditor gesetzt werden.

INTERLIS > Options > Log Table
Erzeugt für jede gelesene INTERLIS-Tabelle einen Eintrag in der Logdatei.

INTERLIS > Options > Trace
Erzeugt für jedes gelesene INTERLIS-Objekt einen Eintrag in der Logdatei.

INTERLIS > Options > Statistics
Gibt am Ende der Logdatei eine Statistik über alle gelesenen INTERLIS-Objekte aus.

DB > Options > Statistics
Gibt amEnde der Logdatei eine Statistik über alle geschriebenden Datenbank-Objekte
aus.
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DB > Options > Set Stroke Tolerance
Definiert ob und wie Kreisbögen aufgelöst werden sollen.

Das Stroken ist im iG/Script Benuzterhanbuch unter derMethode ICS.STROKE beschrie-
ben.

Einige Datenbanksystem kennen keine Kreisbögen - zum Beispiel die OGC Impleme-
tationen inMySQL oder PostGres. Für diese Datenbanksystememüssen die Kreisbögen
aufgelöst werden.

4.3.8. Parameter Module
Datenbanksysteme können komplex sein. Die ICS Datenbank Output Module unterstützen
diverse Parameter für die spezifischen Datenbanksysteme. Diese Parameter werden nicht alle
vom Konfigurationseditor direkt abgehandelt. Für diese Parameter beachten Sie die Beschrei-
bung der entsprechenden Datenbank Output Module im ICS Konfigurationshandbuch.
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B. Begriffe

INTERLIS
Eine ursprünglich im Auftrag der eidgenössischen Vermessungsdirektion entwickelte
Datenmodellierungssprache (DML) [1]. INTERLIS eignet sich besonders für die Be-
schreibung vonDatenmodellen aus der amtlichen Vermessung (z.B. AV93 oder DM01).
INTERLIS kann jedoch auch für die Beschreibung von Datenmodellen aus anderen
Bereichen z.B. Leitungskataster, Umweltschutz etc. eingesetzt werden.

AV93
Ein in INTERLIS definiertes Datenmodell für die amtl. Vermessung [3].
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DM01
Ein in INTERLIS definiertes Datenmodell für die amtl. Vermessung [4].

AVS
Amtliche Vermessungs Schnittstelle. Jedes in INTERLIS beschriebenes Datenmodell
definiert automatisch ein Transferformat für den Datenaustausch. Die AVS ist das
Transferformat für das Datenmodell AV93/DM01.

INTERLIS-Modelldatei
Die INTERLIS-Modelldatei (Endung .ili) ist eine ASCII Datei in dem ein konkretes
INTERLIS Datenmodell mittels INTERLIS beschrieben ist [1][2] .

INTERLIS-Transferdatei
Ein nach den Regeln des Transferformats aufgebaute ASCII/XML Datei (INTERLIS
1:Endung .itf, INTERLIS 2:Endung .xtf). Eine Transferdatei kann nur zusammen mit
dem zugehörigen INTERLIS Modelldatei zweifelsfrei gelesen werden.
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