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1. Einleitung
Das IL2COV Benutzerhandbuch beschreibt den infoGrips INTERLIS => ESRI-
Interchange-File Translator Version (kurz IL2COV). Mit IL2COV können beliebige
INTERLIS-Transferdateien in ESRI-Interchage-Dateien (= E00-Format von ESRI
ArcInfo) umgewandelt werden. IL2COV kann sehr flexibel auf die Bedürfnisse des
Benutzers konfiguriert werden. IL2COV verfügt dazu über folgende Eigenschaften:

• Einen eingebauten INTERLIS-Compiler.

• Automatische Topologieberechnung für AREA- und SURFACE-Typen.

• Volle Programmierbarkteit mit der Skriptsprache iG/Script.

Trotz der Flexibilität bleibt die Konfigurierung von IL2COV einfach und kann auch von
gelegentlichen Benutzern durchgeführt werden. Dies wird vor allem durch den IL2COV-
Konfigurationseditor ermöglicht, mit dem IL2COV-Konfigurationen über eine
Windowsoberfläche editiert werden können. Im Lieferumfang von IL2COV ist ausserdem
eine Konfiguration für das INTERLIS-Datenmodell AV93 enthalten, so dass der
Benutzer IL2COV auch ohne eigenen Konfigurationsaufwand direkt einsetzen kann.

IL2COV ist ein Bestandteil des Produktes INTERLIS Tools Professional, kann aber
auch einzeln lizenziert werden.

1.1 Allgemeines zu IL2COV
Die Software IL2COV besteht aus folgenden Teilen:

1. Der ICS-Runtimeumgebung. Mit der Runtimeumgebung können die mit dem
Konfigurationseditor erstellten Konfigurationen mit dem infoGrips Conversion Sy-
stem (ICS) ausgeführt werden. Die Bedienung der ICS-Runtimeumgebung ist in
Kapitel 3 beschrieben.

2. Dem IL2COV-Konfigurationseditor. Mit dem Konfigurationseditor können
neue Konfigurationen generiert oder bestehende Konfigurationen angepasst
werden. Der Konfigurationseditor ist in Kapitel 4 beschrieben.

In der  folgenden Graphik ist der allgemeine Aufbau der Software dargestellt:

steuert

Konfiguration
iG/Script

ESRI-Interchange E00INTERLIS-itf

Input Output
ICS-Runtime

Library Interpreter
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1.2 Aufbau des Handbuchs
Das Benutzerhandbuch ist wie folgt aufgebaut:

• In Kapitel 2 wird die Installation von IL2COV beschrieben.

• In Kapitel 3 wird die Bedienung der ICS-Runtimeumgebung beschrieben.

• In den Kapiteln 4 ist der IL2COV-Konfigurationseditor beschrieben.

• In Kaptiel 5 wird auf die fortgeschrittenen Konfigurationsmöglichkeiten mit
iG/Script eingegangen.

• Im Anhang ist das Literaturverzeichnis, die Verzeichnisstruktur und ein
Begriffsverzeichnis enthalten.

Konventionen:

fett Definitionen, Funktions- und Produktnamen, Menüeinträge.
courier Eingaben im Betriebssystem oder Dateien.
kursiv Dateinamen.
[1] Verweis auf das Literaturverzeichnis im Anhang.

1.3 Ergänzende Dokumentationen
Das Benutzerhandbuch wird durch folgende Dokumentationen ergänzt:

• INTERLIS Tools Benutzerhandbuch zur Installation und Bedienung der
INTERLIS Tools.

• iG/Script Benutzer- und Referenzhandbuch. Im iG/Script Benutzer und Refe-
renzhandbuch ist die Skriptsprache iG/Script im Detail beschrieben.

• ICS Konfigurationshandbuch. In diesem Handbuch sind alle in einer IL2COV
Konfiguration zur Verfügung stehenden Prozeduren und Methoden beschrieben.

• INTERLIS ein Daten-Austausch-Mechanismus für Landinformationssysteme.
Beschreibt die Datenmodellierungssprache INTERLIS.
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2. Installation
Der IL2COV Konfigurationseditor ist ein Bestandteil der INTERLIS Tools und wird mit
den INTERLIS Tools installiert und lizenziert.
Beachten Sie daher die Installationsanleitung im INTERLIS Tools Benutzerhandbuch
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3. Bedienung

3.1 Bedienung mit ICS for Windows
Nachfolgend ist die Bedienung der ICS-Runtimeumgebung mit der Oberfläche ICS for
Windows beschrieben:

1. Aktivieren Sie das Programm über den Windows Start-Knopf mit:

Start > Programme > infoGrips INTERLIS Tools > ICS for Windows

2. Wählen Sie mit System Script ... die Konfiguration Grunddatensatz.cfg
(oder die von Ihnen gewünschte Konfiguration) im Unterverzeichnis IL2COV aus.

3. Starten Sie die Konfiguration Grunddatensatz.cfg mit Run.

4. ICS for Windows fragt die INTERLIS-Inputdatei und das Coverage Output-
Directory ab. Bemerkung: Falls Sie die Eingabe mit Abbrechen abschliessen,
wird auch der Skript abgebrochen. Weiter mit Schritt 2, 3 oder Cancel.

5. ICS for Windows übersetzt nun die Inputdatei. Die Outputdateien werden im
Outputverzeichnis erzeugt. Fehlermeldungen werden in die Logdatei
ILTOOLS_DIR\data\temp\ics.log geschrieben.

6.  Sie können die Logdatei nach Beendigung des Skripts mit Show Log anzeigen.

Während der Übersetzung wird die Anzahl INTERLIS-Inputobjekte und die Anzahl er-
zeuger ESRI-Interchange-Objekte angezeigt. Die Anzahl der Input- und Outputobjekte
ist normalerweise nicht identisch. Die Anzahl hängt von der gewählten Konfiguration
und der Struktur des INTERLIS- bzw. ESRI-Interchange-Datenmodells ab.
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Import der ESRI-Interchange-Files nach ArcInfo

Nach der Uebersetzung steht ebenfalls ein AML-File (AML = ARC Macro Language)
bereit, um die ESRI-Interchange-Files einfach in ArcInfo zu importieren. Das File hat
denselben Namen wie die INTERLIS-Inputdatei, aber mit der Endung .aml (z.B.
td.itf => td.aml) .

Gehen Sie beim Import in ArcInfo wie folgt vor:

1. Starten Sie ArcToolbox.

2. Wählen Sie
Conversion Tools > Import to Coverage >
Interchange File to Coverage

3. Aktivieren Sie in dem erscheinenden Menu den Button Batch

4. Selektieren Sie unter dem Button Open AML das entsprechenden AML-File z.B.
td.aml

5. Aktivieren Sie zum Import den Button Ok
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3.2 Bedienung über ein DOS-Fenster
In einem DOS-Fenster kann IL2COV wie folgt aufgerufen werden:

IL2COV <Konfigurationsdatei> <Transferdatei> <Verzeichnis>

Für <Konfigurationsdatei> geben Sie die IL2COV-Konfiguration an die Sie
benutzen wollen (z.B. Grunddatensatz.cfg). Für <Transferdatei> geben Sie die zu
übersetzende INTERLIS-Transferdatei und für <Verzeichnis> das Outputverzeichnis
an. IL2COV übersetzt darauf die Inputdatei und gibt Meldungen und Fehler auf den
Bildschirm bzw. in die Logdatei ics.log aus. Sie können die Logdatei mit jedem Texteditor
anzeigen oder ausdrucken.

Damit Sie IL2COV von der DOS Kommandozeile aus in einem beliebigen Verzeichnis
starten können, müssen Sie die PATH-Variable um das bin-Verzeichnis von
ICS for Windows erweitern. Die Variable können Sie wie folgt
definieren:

• Öffnen Sie in der Windows-Systemsteuerung:

System>Erweitert>Umgebungsvariablen

• Definieren oder erweitern Sie die Variable PATH als Systemvariable oder
Benutzervariable um den Anteil

c:\iltools\system\bin

 (Annahme: die INTERLIS Tools  wurde unter c:\iltools installiert).

• Melden Sie sich in Ihrem System ab und wieder an, oder starten Sie den PC neu.
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4. IL2COV-Konfigurationseditor
Mit IL2COV wird die Basiskonfiguration Grunddatensatz.cfg mitgeliefert. Die
Konfiguration Grunddatensatz.cfg ist für das Datenmodell AV93 (offizielles Datenmodell
der V+D) vorkonfiguriert. Mit dem Konfigurationseditor kann der Benutzer die
mitgelieferte Konfiguration anpassen oder neue Konfigurationen erstellen. Bemerkung:
IL2COV-Konfigurationen sollten nur mit dem Konfigurationseditor und nie von Hand
editiert werden.

4.1 Starten des Konfigurationseditors
Aktivieren Sie das Programm über den Windows Start-Knopf mit
Start>Programme>INTERLIS Tools 1.5>IL2COV Konfigurationseditor. Falls der
Konfigurationseditor korrekt installiert wurde, erscheint das Hauptmenü des
Konfigurationseditors auf dem Bildschirm:

Der Konfigurationseditor ist nun für das Bearbeiten von Konfigurationen bereit. Der
Konfigurationseditor kann mit File>Exit wieder verlassen werden. Bemerkung: Der
Konfigurationseditor registiert die wichtigsten Benutzeraktionen in der Logdatei
ILTOOLS_DIR\temp\covedit.log. Die Logdatei kann mit File>Show Log ...
angezeigt werden.

4.2 Laden und Anzeigen von Konfigurationen
Wählen Sie mit File>Open User ... oder File>Open System ... die
Konfiguration aus die Sie anzeigen wollen. Im View INTERLIS Objects werden alle
verfügbaren INTERLIS-Topics der aktuellen Konfiguration angezeigt. Falls Sie auf das +
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Zeichen neben einem Topic klicken, werden alle Tabellen des Topics unterhalb des Topics
dargestellt. Sie können nun auf eine Tabelle klicken. Die Attribute der Tabelle werden im
View Attributes of <Table> dargestellt:

Im View Attributes of <Table> werden neben den Attributnamen auch die Typen
der Attribute dargestellt (z.B. Atttribut Nummer, Typ TEXT). Die Typenbezeichungen
entsprechen den INTERLIS-Bezeichnungen bis auf folgenden Ausnahmen:

TID: Transferidentifikation (nur für Attribut OBJID möglich).
IRANGE: Wertebereich von ganzen Zahlen (z.B. [0 .. 10]).
RRANGE: Wertebereich von reellen Zahlen (z.B. [0.0 .. 1.0]).
ENUM: Aufzählungstyp.

Ausserdem werden folgende spezielle Attribute dargestellt:

OBJID: Dieses Attribut enthält die Transferidentifikation.
GEOM: Linienattribut aus AREA- oder SURFACE-Tabellen.

Z.B. BoFlaeche_Geometrie oder
           LFPNachführung_Perimeter.

GEOM wird auch für mit dem Topologiemodul berechnete Flächen
angezeigt.

REFID: Beziehungsattribut aus SURFACE-Tabellen.
Attr_TXT: Textdarstellung eines Aufzählungsattributs Attr.

Falls zu der INTERLIS-Tabelle ESRI-Interchange-Objekte konfiguriert wurden, werden
diese im View COV Objects dargestellt:

Die Felder der COV-Objekte sind in die Gruppen Parameters und Attributes unter-
teilt. Die Gruppe Parameters enthält Felder die die geometrische Lage des Objekts
beinflussen (z.B. Geom = Position). Die Gruppe Attributes enthält die COV-
Objektattribute (z.B. File). Bei mehreren COV-Objekten pro Tabelle, wird nur ein COV-
Objekt auf einmal angezeigt. Sie können die anderen COV-Objekte anzeigen, in dem Sie
auf den Reiter des gewünschten Objekts klicken. Bemerkung: Falls zu einer INTERLIS-
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Tabelle COV-Objekte konfiguriert wurden, dann erscheint neben der INTERLIS-Tabelle
ein blaues Kreuz im View INTERLIS Objects.

Spezielle Darstellungen
Falls auf der linken Seite einer Tabelle ein + Zeichen zu sehen ist, sind zu dieser Tabelle
Zusatzkriterien definiert worden. Sie können die Zusatzkriterien anzeigen, indem Sie auf
das + Zeichen klicken. Es ist möglich, dass in einem Zusatzkriterium weitere Zusatzkri-
terien definiert wurden (in diesem Fall steht links des Zusatzkriteriums ein + Zeichen).

Falls neben einem Attribut im Attributview ein + Zeichen steht, handelt es sich bei dem
Attribut um ein Beziehungsattribut. Falls Sie auf das + Zeichen klicken, werden die
Attribute der referenzierten Tabelle angezeigt (hier: Beziehungsattribut Entstehung
mit Attributen aus der referenzierten Tabelle LFPNachführung).

4.3 Erzeugen von neuen Konfigurationen
So erstellen Sie eine neue Konfiguration:

1. Wählen Sie File>New

2. Im Untermenü wählen Sie das INTERLIS-Modell aus (.ili). Das Modell kann
entweder aus ILTOOLS_DIR\user\models (User ...) oder
ILTOOLS\system\models (System ...) ausgewählt werden.

3. Mit OK wird die neue Konfiguration für Sie erstellt (noname.cfg). Die Konfigura-
tion kann nun wie unter 4.4 beschrieben, editiert werden.

4.4 Ändern einer Konfiguration

Definieren von Zusatzkriterien
Falls Sie Objekte aus der gleichen INTERLIS-Tabelle in COV unterschiedlich abbilden
möchten, müssen Sie Zusatzkriterien für die Tabelle definieren. So definieren Sie
Zusatzkriterien:
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1. Wählen Sie die Tabelle aus.

2. Wählen Sie aus ein Attribut vom Typ ENUM aus.

3. Klicken Sie auf INTERLIS>New Condition.

4. Der Konfigurationseditor fügt darauf alle möglichen Werte des Aufzählungsattri-
buts als neue Zusatzkriterien ein.

Bemerkungen:
• Zusatzkriterien könnnen mit INTERLIS>Delete Condition gelöscht werden.

• Es ist möglich innerhalb eines Zusatzkriteriums weitere Zusatzkriterien zu defi-
nieren.

• Sie können für INTERLIS-Topics keine Zusatzkriterien definieren.

Erzeugen neuer COV-Objekte
Wählen Sie eine Tabelle oder ein Zusatzkriterium aus. Wählen Sie mit COV>New den ge-
wünschten Objekttyp aus. Das neue Objekt wird der ausgewählten Tabelle oder dem
ausgewählten Kriterium zugeordnet. Bemerkung: Der Objekttyp Text ist im COV-
Format nicht direkt vorhanden. Falls Sie Objekte vom Typ Text konfigurieren, werden
diese bei der Übersetzung automatisch in Polylinienobjekte umgewandelt.

Editieren eines COV-Objekts
Wählen Sie ein COV-Objekt wie unter 4.2 beschrieben aus. Sie können nun in die einzel-
nen Felder des COV-Objekts Werte eingeben. Sie haben folgende Möglichkeiten um
Werte einzugeben:

• Im Attribut File muss die COV-Outputdatei angegeben werden. Diese Angabe ist
für alle COV-Objekte obligatorisch. Der Name der Ouptutdatei muss ohne Endung
angegeben werden. Später für jedes COV-Objekt eine Datei <File>.e00 erzeugt
werden. Sie können für jedes COV-Objekt eine andere Datei angeben. Es ist jedoch
auch möglich mehre COV-Objekte in der gleichen Datei zu speichern. Allerdings
muss dann der Grundtyp der COV-Objekte (Punkt, Polylinie oder Polygon)
zusammenpassen. Z.B. ist es nicht möglich ein Punktobjekt in einer Liniendatei zu
speichern. Zudem muss die Record-Struktur für die COV-Objekte identisch sein.

• Sie können Konstanten von Hand eintragen, z.B. 0.0 für das Attribut Rot
(Textobjekt).

• Sie können Attributnamen als Wert eintragen. Attributnamen können eingetragen
werden, indem Sie den Attributnamen aus dem View INTERLIS Attributes
auf ein Feld des COV-Objekts ziehen (Mauspfeil über dem Attribut positionieren
und linke Maustaste festhalten und auf das Zielfeld ziehen, Drag and Drop). Ach-
tung: Falls Sie Attributnamen von Hand eintragen, muss der Name mit IN. be-
ginnen damit IL2COV den Namen von Konstanten unterscheiden kann.
Ausserdem muss der Name ein gültiger Attributname der aktuellen Tabelle sein.
Falsche Eingaben führen zu Fehlermeldungen beim Ausführen des Skripts.

Bemerkungen:

• Beim Ziehen von Attributnamen auf Felder muss darauf geachtet werden, dass der
Typ des Attributs mit dem Feld zusammenpasst (Aufzählungsattribute sollte z.B.
nicht auf Positionsfelder gezogen werden). Falls der Typ des Attributs mit dem
Feld nicht zusammen passt, versucht IL2COV den Typ automatisch zu wandeln.
Falls der Attribut- und der Feldtyp inkompatibel sind, führt dies zur Laufzeit zu
Fehlermeldungen.
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• Felder die mit einem * markiert sind müssen immer ausgefüllt werden. Z.B. muss
das Feld File immer angegeben werden.

• Falls Sie ein GEOM-Attribut aus einem Area-View auf das Geometriefeld eines
Polygonobjekts ziehen, bewirkt dies die automatische Berechnung der
Flächentopologie. Die neu berechneten Objekte enthalten in IN.GEOM die
Flächengeometrie.

• Falls Sie ein GEOM-Attribut aus einem Boundary-View auf das Geometriefeld eines
Polylineobjekts ziehen, bewirkt dies die automatische Berechnung der
Flächentopologie. Die neu berechneten Objekte enthalten in IN.GEOM die
Geometrie der Begrenzungslinie und in IN.LEFT bzw. in IN.RIGHT einen
Verweis auf das Objekt links bzw. rechts der Linie.

Sachdaten
Falls Sie zu einem COV-Objekt Sachdaten konfigurieren wollen, müssen Sie zuerst das
COV-Objekt erzeugen und unmittelbar danach ein Objekt vom Typ Record.

Oben wurde z.B. zuerst ein Polygonobjekt und danach die dazugehörigen Sachdaten
konfiguriert. Die einzelnen Attribute werden wie folgt definiert:

1. Tragen Sie unter Name den Namen des Attributs ein (z.B. ART).
Die Länge des Namens eines Attributes, darf nich mehr als 16 Zeichen betragen.

2. Tragen Sie unter Type den Typ des Attributs ein.
Die Typ-Angabe hat folgendes Format:

TYPE(<Width>[;<Display-Width>])

TYP: ArcInfo-Type
Width: ArcInfo-Type Width
Display-Width: ArcInfo-Type Display-Width - Optional

Falls die Optionalen Format-Definitionen nicht definiert werden, werden Default-
Format-Definitionen erstellt.

Die zulässigen Format-Definitionen sind:

CHAR(<Width>[;<Display-Width>])
Zeichenkette mit Länge <Width>.
Zeichenkette mit Display-Länge <Display-Width>.
Width = 1-320
Display-Width Optional, Default Display-Width = Width
z.B. CHAR(80), CHAR(10;20)
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NUMBER(<Width>[;Display-Width[.<Decimals>]])
Reelle Zahl mit Länge <Width>.
Reelle Zahl mit Display-Länge <Display-Width> inklusive Dezimal-Punkt.
Reelle Zahl mit Anzahl Dezimalstellen <Decimals>.
Width = 1-16
Display-Width Optional, Default Display-Width = Width
Decimals Optional, Default Decimals = 0
z.B. Number(8), Number(8;10), Number(8;10.3)

INTEGER(<Width>[;<Display-Width>])
Ganze Zahl mit Länge <Width>,
Ganze Zahl mit Display-Länge <Display-Width>.
Width = 1-16
Display-Width Optional, Default Display-Width = Width
 z.B. INTEGER(8), INTEGER(8;10)

BINARY(<Width>[;<Display-Width>])
Ganze Zahl mit Länge <Width>.
Ganze Zahl mit Display-Länge <Display-Width>.
Width = 2|4
Display-Width Optional, Default Display-Width = 8
 z.B. BINARY(4), INTEGER(4;5)

FLOAT(<Width>[;Display-Width[.<Decimals>]])
Reelle Zahl mit Länge <Width>.
Reelle Zahl mit Display-Länge <Display-Width> inklusive Dezimal-Punkt.
Reelle Zahl mit Anzahl Dezimalstellen <Decimals>.
Width = 4|8
Display-Width Optional, Default Display-Width = 18
Decimals Optional, Default Decimals = 5
z.B. FLOAT(8), FLOAT(8;12), FLOAT(8;12.3)

DATE(<Width>[;<Display-Width>])
Datum mit Länge <Width>
Datum mit Display-Länge <Display-Width>.
Width = 8
Display-Width Optional, Default Display-Width = 10
z.B. DATE(8), DATE(8;10)

3. Tragen Sie unter Value den Wert des Attributs ein. Für den Wert können
Konstanten (z.B. Wiese) oder INTERLIS-Attributnamen (z.B. IN.Art_TXT)
eingetragen werden. Bemerkung: INTERLIS-Attributnamen können auch via Drag
and Drop eingetragen werden.
Falls Sie ein Attribut ohne Wert für eine spätere Erfassung unter ArcInfo
definieren möchten, so lassen Sie das Feld für den Wert einfach unausgefüllt.

4. Klicken Sie auf Create.

Mit Update können die Attributdefinitionen editiert und mit Delete auch wieder
gelöscht werden. Dazu muss das entsprechende Attribut zuerst unter Attributes
selektiert werden.
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Kopieren von COV-Objekten
Falls Sie ein bestehendes COV-Objekt an einen anderen Ort kopieren möchten:

1. Wählen Sie das COV-Objekt aus.

2. Selektieren Sie COV>Copy.

3. Wählen Sie die Tabelle oder das Zusatzkriterium aus wohin das Objekt kopiert
werden soll.

4. Selektieren Sie COV>Paste.

Löschen von COV-Objekten
Falls Sie ein bestehendes Objekt löschen wollen:

1. Wählen Sie das COV-Objekt aus.

2. Selektieren Sie COV>Delete.

4.5 Setzen von Optionen

INTERLIS-Optionen
Im Menü INTERLIS>Options können folgende Optionen ein- oder ausgeschaltet wer-
den:

LOG_TABLE
Erzeugt für jede gelesene INTERLIS-Tabelle im Logfile ics.log einen Eintrag.

TRACE
Erzeugt für jedes gelesene INTERLIS-Objekt einen Eintrag in der Logdatei.

STATISTICS
Gibt am Ende der Logdatei eine Statistik über alle gelesenen INTERLIS-Objekte
aus.

COV-Optionen
Im Menü COV>Set Stroke Tolerance kann die Stroketroleranz angegeben werden
mit der Kreisbogen durch Polyliniensegmente approximiert werden (Default: 0.01).
Ein Kreisbogen wird gleichmässig in Liniensegemente aufgelöst, bis die Toleranz unterschritten
ist.
tolerance > 0.0 :
Die Toleranz ergibt sich aus dem Verhältnis der Pfeilhöhe zum Radius eines Kreisbogens.
tolerance = 0.0:
Der Kreisbogen wird in den Anfangs- und Endpunkt und dem Punkt auf dem Kreisbogen
aufgelöst.
tolerance < 0.0 :
Die Toleranz ist ein absoluter Wert in Meter, der die maximale Pfeilhöhe definiert.

Bemerkungen:

Die Stroketoleranz beeinflusst die Topolgieberechnung nicht, d.h. die Topologie wird
immer mit Kreisbögen gerechnet. Da das COV-Format jedoch keine Kreisbögen
unterstützt, müssen Kreisbögen unmittelbar vor dem Schreiben in die Ouputdatei in
Polylinien aufgelöst werden.
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Für die COV-Objekte Polyline, Polygon, PolygonBoundary und Region kann
die Stroketoleranz auch lokal gesetzt werden. Falls für diese Objekte keine lokale
Stroketoleranz definiert wurde, gilt die globale Stroketoleranz.

Im Menü COV>Options können folgende Optionen ein- oder ausgeschaltet werden:

STATISTICS
Gibt am Ende der Logdatei eine Statistik über alle geschriebenen COV-Objekte
aus.
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4.6 Speichern der Konfiguration
Falls Sie die von Ihnen veränderte oder erzeugte Konfiguration speichern wollen:

1. Wählen Sie aus dem File-Menü File>Save oder File>Save As .. aus.

2. File>Save sichert die Konfiguration unter dem aktuellen Namen (der aktuelle
Name ist wird in der Titelleiste des Konfigurationseditors eingeblendet).

3. Mit File>Save As .. können Sie einen neuen Namen angeben.

Das Speichern der Konfiguration erzeugt für Sie automatisch ein iG/Script Programm.
Die vom Konfigurationseditor erzeugten Konfigurationen sollten Sie nicht von Hand
editieren. Die neue Konfiguration können Sie mit der ICS-Runtimeumgebung ausführen
(s.a. Kapitel 3).

Hinweis: Konfigurationen werden immer unter ILTOOLS_DIR\user\script\il2cov
gespeichert auch wenn sie ursprünglich aus ILTOOLS_DIR\system\script\il2cov
geladen wurden. Damit wird verhindert, dass Systemkonfigurationen versehentlich
verändert werden.

4.7 Bemerkungen zu COV-Objekttyp Polygon
Polygone (Flächennetze) könne Sie in ESRI-Interchange-Files auf zwei Arten erzeugen:

• Sie schreiben die berechneten Flächen direkt mit dem COV-Objekttyp Polygon in
die Output-Datei.

z.B.
INTERLIS-Objekt Topic:Bodenbedeckung, Table:BoFlaeche_Area.

Die Table BoFlaeche_Area ist im INTERLIS-Modell nicht enthalten, wird aber
vom TOPO-Modul zur Verfügung gestellt und enthält die berechneten Flächen
inklusive aller Attribute.

• Sie schreiben die Flächenbegrenzungslinien mit dem COV-Objekttyp
PolygonBoundary und die Flächencentroide mit dem COV-Objekttyp
PolygonCentroid separat  in die Output-Datei.
Achten Sie darauf das für beide Objekte der Namen der Output-Datei identisch ist.

z.B.
INTERLIS-Boundary-Objekt:
Topic:Bodenbedeckung, Table:BoFlaeche_Geometrie.
INTERLIS-Centroid-Objekt:
Topic:Bodenbedeckung, Table:BoFlaeche.

Mit den Centroiden und den Boundaries wird bei der Uebersetzung mit dem
TOPO-Modul das Flächennetz berechnet und in die Output-Datei geschrieben.
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5. Fortgeschrittene Konfiguration
Normalerweise werden Sie mit den in Kapitel 4 beschriebenen Möglichkeiten des
Konfigurationseditors auskommen. Es kann jedoch sein, dass Sie auf die Berechnung von
Werten aus bestehenden Attributen angewiesen sind. In diesem Falls steht Ihnen die
ganze Funktionalität der Skriptsprache iG/Script zur Verfügung.

Problem: Im INTERLIS-Modell Grunddatensatz.ili soll für Höhenpunkte ein
Punkt dargestellt und die Höhe als Attribut abgespeichert werden. Die
Höhen ist jedoch in Grunddatensatz.ili nicht direkt sondern nur indirekt
über das Attribut IN.Geometrie (3D-Koordinate) verfügbar.

Lösung: Aus dem Attribut IN.Geometrie wird mit iG/Script ein neues Attribut
IN.Hoehe berechnet und dieses dann als Attributwert benutzt.

Die Umsetzung des obigen Beipiels soll nun in den folgenden Abschnitten erläutert wer-
den. Die Sprache iG/Script ist im Detail in dokumentiert.

5.1 Benutzerprozeduren
Sie können iG/Script Programmcode nicht direkt mit dem Konfigurationseditor eingeben.
Sie müssen iG/Script Prozeduren in der Datei
ILTOOLS_DIR\script\il2cov\il2cov.out mit einem Texteditor (z.B.
notepad.exe) definieren. Für die Berechnung der Höhenkote geben Sie z.B. folgende
Prozedur ein:

PROCEDURE HOEHE0
IN.Geometrie POINTZ TO_STRING '1' ROUND => IN.Hoehe

END_PROCEDURE

Die Prozedur HOEHE0 berechnet nun aus dem Attribut IN.Geometrie wie gewünscht
das Attribut IN.Hoehe (gerundet auf 1 Nachkommastelle). Sie können die neue Proze-
dur mit dem Konfigurationseditor in Ihre Konfiguration einbauen, indem Sie im Menü
COV>New>Procedure auswählen und im Feld Procedure Name die neue Prozedur
aus der Werteliste auswählen.
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Wir können nun den Hoehenpunkt fertig konfigurieren. Zuerst wurde die Prozedur
definiert. Danach haben wir den Punkt eingefügt und zuletzt einen Record zum Punkt
definiert. Beachten Sie, dass die Berechnung von IN.Hoehe vor der Benutzung von
IN.Hoehe im Recordobjekt (Feld HOEHE) definiert werden muss. Bemerkung: Das
Attribut IN.Hoehe muss von Hand eintragen werden, da das Attribut erst zur Laufzeit
der ICS-Runtimeumgebung bekannt ist.

5.2 Parameterübergabe
Es ist möglich den Benutzerprozeduren Argumente zu übergeben. Die Benutzerprozedu-
ren müssen für die Abfrage der Parameterwerte folgende Prozeduren verwenden:

GET_PARAM beliebiges Attribut.
GET_IPARAM Integer-Attribut oder Integer-Konstante.
GET_RPARAM Real-Attribut oder Real-Konstante.
GET_SPARAM String-Attribut oder String-Konstante.
GET_PPARAM Punkt-Attribut oder Punkt-Konstante.
GET_LPARAM Linien-Attribut.
GET_APARAM Flaechen-Attribut.

Beispiel:

PROCEDURE HOEHE1 ! Punktgeometrie
GET_PPARAM POINTZ TO_STRING '1' ROUND => IN.Hoehe

END_PROCEDURE

Die Prozedur HOEHE1 berechnet die Hoehe für ein beliebiges Punktattribut. Die neue
Prozedur kann z.B. für die Berechnung der Höhenkote wie folgt benutzt werden:
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6. Konfigurationen im Produkt
Das Produkt beinhaltet bereits Konfigurationen, die Sie Anwenden können. Diese
Konfigurationen werden nachfolgend beschrieben.

6.1 Konfiguration IL2COVGEN.cfg
Die Konfiguration IL2COVGEN.cfg übersetzt eine beliebige INTERLIS-
Transferdatei in ESRI-Interchange-Files. Neben dem Transfer der INTERLIS-
Transferdatei erstellt die Konfiguration auch eine IL2COV-Konfiguration für das in
der INTERLIS-Transferdatei enthaltene INTERLIS-Modell. Diese IL2COV-
Konfiguration können Sie mit dem Konfigurations-Editor bei Bedarf
nachbearbeiten.
Nachfolgend ist die Bedienung der Konfiguration IL2COVGEN.cfg beschrieben:

1. Aktivieren Sie das Programm über den Windows Start-Knopf:

2. Wählen Sie mit System Script ... die Konfiguration il2covgen.cfg  im
Unterverzeichnis IL2COV aus.

3. Starten Sie die Konfiguration il2covgen.cfg mit Run.

4. ICS for Windows fragt Sie zuerst nach der INTERLIS-Inputdatei und dann nach
einer Datei im ESRI-Interchange-File-Outputdirectory ab.
Bemerkung: Falls Sie die Eingabe mit Abbrechen abschliessen, wird auch der
Skript abgebrochen. Weiter mit Schritt 2, 3 oder Cancel.

5. ICS for Windows ermittelt aus der INTERLIS-Inputdatei das INTERLIS-Modell
und bietet in einer Liste alle Themen und Objekte als Topics und Tables zur
Uebersetzung an.



infoGrips GmbH, Zürich INTERLIS Tools IL2COV
Benutzerhandbuch

© infoGrips GmbH, 2002-2010 Seite 20

Selektieren Sie die zu übersetzenden Themen und Objekte und fahren Sie mit OK
weiter.
Bemerkung: Falls Sie die Eingabe mit Cancel abschliessen, wird auch der
Skript abgebrochen. Weiter mit Schritt 2, 3 oder Cancel.

6. ICS for Windows übersetzt nun die Inputdatei in die Outputdateien im Output-
Directory. Fehlermeldungen werden in die Logdatei
ILTOOLS_DIR\temp\ics.log geschrieben.

Zudem wird im Verzeichnis ILTOOLS_DIR\user\script\il2cov eine IL2COV-
Konfiguration angelegt.
Diese Konfigurationen erhält als Filenamen den Modellnamen des INTERLIS-
Inputfiles und die Extension cfg .

Beispiel: INTERLIS-Modell: Grunddatensatz
IL2COV-Konfiguration: Grunddatensatz.cfg

Diese Konfiguration kann mit dem IL2COV-Konfigurationseditor nachbearbeitet
werden und mit dem IL2COV-Translator können entsprechend INTERLIS-Daten
nach ESRI-Interchange-Files übersetzt werden.
Für das dazu notwendige Produkt IL2COV benötigen Sie allerdings eine
entsprechende Lizenz.

7. Sie können die Logdatei nach Beendigung des Skripts mit Show Log anzeigen.

6.2 Konfiguration Grunddatensatz.cfg
Die Konfiguration Grunddatensatz.cfg übersetzt eine INTERLIS-Transferdatei im
AV93-INTERLIS-Modell nach ESRI-Interchange-Files. Die Konfiguration
Grunddatensatz.cfg  ist eine mit dem Konfigurations-Editor erstellte Konfiguration.
Die Konfiguration übersetzt nur ausgewählte Objekte.
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